Premiere Elements: No thumbnail for certain videos in Elements 11 organizer

  • 2
  • Problem
  • Updated 5 years ago
  • (Edited)
Elements organizer 11 will not show any thumbnail for MP4 videos imported from my phone. Windows Explorer is able to show thumbnails, as is Lightroom and ACDsee, so I don't think there's any sort of codec issue on my machine. Organizer can play the videos (and PE can edit them), there is simply no thumbnail shown. Clicking on "update thumbnail" makes no difference.
Photo of Paul Galbraith

Paul Galbraith

  • 4 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 2
Photo of Paul Galbraith

Paul Galbraith

  • 4 Posts
  • 0 Reply Likes
I spent 90 minutes on Adobe's chat help for this problem. I was able to show that there's no issue with the codec on my machine (as every other program, including the premiere editor) has no problem viewing/editing the video. The poor guy tried everything and finally came to the same conclusion as me. He was going to open a defect, but was overruled by his manager because my camera is not "officially" supported here:

http://helpx.adobe.com/premiere-eleme...

So, Adobe is neither willing to "officially" acknowledge the defect, nor are they willing to do anything about it. Very disappointing.
Photo of Craig Baldwin

Craig Baldwin

  • 1 Post
  • 0 Reply Likes
I have been struggling with this same frustrating issue for a long time. The problem seems to be they have built-in some hardcoded dependency on Quicktime. Against my better judgment I installed Quicktime and while it does give me thumbnails in the Organizer (PSE 8) it results in very poor, choppy playback of the videos in the PSE player where I got very smooth playback before with my other non-Quicktime codecs. So, it is either terrible playback with thumbnails or good playback with no thumbnails. Too bad they won't allow us to add our own custom thumbnails.
Photo of Paul Galbraith

Paul Galbraith

  • 4 Posts
  • 0 Reply Likes
I just tried with PE 12, still the same issue (I have quicktime installed, and every other photo editor I've tried has no issues with thumbnails). I've upgraded every year for several years, but not this time. I guess I'll wait until a competitor adds the elements features that I like to a competing product, or adobe provides better mobile support.