Photoshop CC 2018/2019: No valid asset to export

  • 2
  • Problem
  • Updated 2 months ago
  • (Edited)
I was trying to export my photo from photoshop yesterday and when I press export as, only a blank grey window pop up and shows nothing. 

When I try clicking the Export All button, it said I have no valid asset to export

I tried to generate an image asset in the File Option but it still shows me the same blank export as window.
 
I can still perfectly use the Quick Export function but the fact that the export as function aren't working really bugged me out.
I had this error since Photoshop cc 2018 and I updated it recently to Photoshop cc2019 and still experience the same error. I've tried uninstalling and reinstalling but it still didn't work.
Photo of Kmsvk

Kmsvk

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 10 months ago

  • 2
Photo of Alex Ferrao

Alex Ferrao

  • 1 Post
  • 0 Reply Likes
Photoshop is complete garbage
Photo of Sam Gannaway

Sam Gannaway, Employee

  • 16 Posts
  • 13 Reply Likes
Let's start by checking for an old version of the extension in these two folders:
  • /Library/Application Support/Adobe/CEP/extensions
  • ~/Library/Application Support/Adobe/CEP/extensions
If you find a folder in either containing "crema", for example,  com.adobe.photoshop.crema, delete or move out of that folder.  
Try re-launching Photoshop, and see if Export As loads properly.

If it doesn't, please attach the text provided by Help > System Info.

Sam

Photo of Kmsvk

Kmsvk

  • 2 Posts
  • 0 Reply Likes
I couldn't find any file containing crema on my computer. 
Photo of واقف خٹک

واقف خٹک

  • 3 Posts
  • 0 Reply Likes
export as not working in photoshop cc 2019 ?
Photo of واقف خٹک

واقف خٹک

  • 3 Posts
  • 0 Reply Likes
same problem 
Photo of David Lewis

David Lewis

  • 1 Post
  • 0 Reply Likes
It worked until the latest update.  Needs to be resolved


Photo of Karen Vuong

Karen Vuong

  • 4 Posts
  • 0 Reply Likes
Same issue, so frustrating. Has anyone found a solution?
Photo of Beth Kicker

Beth Kicker

  • 1 Post
  • 0 Reply Likes
I am not sure if it is a good solution or not, but I am going to "save as" instead of "export" it is saving them to my computer. I don't know if it changes srgb or anything, but it saved to my computer. 
Photo of Joy Suzanne

Joy Suzanne

  • 1 Post
  • 0 Reply Likes
I'm also having this issue, is there a solution? (I'm using the creative cloud updated to the latest version on a macbook pro)
Photo of Gábor Vereb

Gábor Vereb

  • 1 Post
  • 0 Reply Likes
Hi Guys,

I faced the same issue, and allowing the outgoing firewall connection for  "Adobe CEP HTML Engine"  solved the probelm. BTW I use avast firewall...
Photo of Roan Grant-Grierson

Roan Grant-Grierson

  • 1 Post
  • 1 Reply Like
This is a serious issue and needs to be resolved. I can not Export as  .. as the OP has detailed
Photo of Adam Blythe

Adam Blythe

  • 2 Posts
  • 0 Reply Likes
it says "extension could not be loaded because of a program error".
com.adobe.photoshop.crema is at its place where its located C:\Program Files\Adobe\Adobe Photoshop CC 2019\Required\CEP\extensions\com.adobe.photoshop.crema, and it has content in it I hope all what is required. Any idea how can I resolve it? or I shouldn't have moved to adobe 2019? as I'm thinking thats what went wrong!

Photo of Adam Blythe

Adam Blythe

  • 2 Posts
  • 0 Reply Likes
Till then, I am working with "Save As".
Photo of Sam Flynn

Sam Flynn

  • 1 Post
  • 0 Reply Likes
I found a solution. 

I work on a Macbook pro and was having this issue. 

Go into the package contents of the photoshop application. To do this right click on the application and select "view package contents" (⁨Applications⁩ ▸ ⁨Adobe Photoshop CC 2019⁩ ▸ ⁨Adobe Photoshop CC 2019⁩ ▸ ⁨Contents⁩ ▸ ⁨Required⁩ ▸ ⁨CEP ▸ Extensions⁩) and find the folder titled com.adobe.photoshop.crema and delete it. 

Relaunch Photoshop and the export as function should now be working. It worked for me anyway!

Photo of Laurie

Laurie

  • 1 Post
  • 0 Reply Likes
Hi everyone, 

Has anyone figured this out yet? I arrived at this forum from a google search - I'm having the same issue while trying to export a file to SVG. I did this with no problem a couple of weeks ago, so it must be an issue with a new update or something? I've tried going back into CC 2017, though, and I'm having the same issue there now, as well. I tried deleting the crema file, but now that window is completely black, whereas it looked like it does above before I deleted it... I need to get this sorted asap, so if anyone has any insight, I'd be much obliged! :) 
Photo of Digão Bacelar

Digão Bacelar

  • 1 Post
  • 0 Reply Likes
Hello guys! Restart PS and open the file again worked for me!

Photo of Simon L Jackson

Simon L Jackson

  • 1 Post
  • 0 Reply Likes
I got around this as follows:
Windows Defender Firewall/ Advanced Settings/ Windows Defender Firewall properties/ Public Profile/ Inbound connections - ALLOW (apply)
If someone can figure out from this info what is causing the problem and how to resolve it more sensibly that would be great!