Lightroom Classic: No scrolling improvements for me...?

  • 1
  • Problem
  • Updated 3 weeks ago
  • (Edited)
I was very happy to read about the new scrolling performance enhancements in the June 2020 release (it's the small fixes that make a bigger difference day to day than tentpole features). I upgraded immediately and I must say I'm seeing no improvement whatsover. In fact, I fear my catalogs may actually be scrolling more slowly now.  The scroll refresh lags way behind my mouse/arrow-key/trackpad scrolling action (yes, I tried all three). Even when it scrolls, it stutters and jerks, making it impossible to get an overview of image thumbnails at a glance. This even happens after I've built 1:1 previews for the images in a collection I'm viewing.

I'm on a 2019 Mac Pro, 2.7 GHz 24-Core, 384 GB RAM, Radeon Pro W5700X. macOS is up-to-date Catalina. 

Monitor is BenQ SW321C. 3840x2160 scaled to a viewable area of 3200x1800. Lightroom scrolling only speeds up if I shrink the window to a size of about 1440x1000. That size is unusable, but I tried it out of curiosity. Is Lightroom not capable of scrolling smoothly at 4k? Even with the horsepower listed above?

My catalog is close to 57k images, almost all Fuji RAFs from the X-T1 and X-H1. I've optimized my catalog and restarted my Mac and Lightroom for good measure. I've ensured Lightroom has access to my GPU.



What am I missing?

 

p.s. - I was thrilled to see that you finally implemented renaming for custom text during batch export only to be crushed when I realized it was only for multi-batch export. WHY?! You guys are killing me! 
Photo of Joseph Rivera

Joseph Rivera

  • 43 Posts
  • 2 Reply Likes
  • annoyed, disappointed

Posted 3 weeks ago

  • 1
Photo of Robert Somrak

Robert Somrak, Champion

  • 726 Posts
  • 227 Reply Likes
You are missing the correct answer from Ian Lyons you got in this thread where you posted the exact same question.

https://community.adobe.com/t5/lightroom-classic/i-m-seeing-zero-scrolling-improvements-in-june-2020...
Photo of Joseph Rivera

Joseph Rivera

  • 43 Posts
  • 2 Reply Likes
Ooh, good stop-gap tip! What I’m really wanting is the ability to export from the right click menu and pick a preset without having to go through the dialog. Then, if the present contains a custom name field, just have it repeated in the dialogue when I’m selecting a location. Pretty basic stuff.
Photo of Mayuri Jain

Mayuri Jain, Employee

  • 90 Posts
  • 36 Reply Likes
Hi Joseph,

Could you please provide below details as it will help us to further investigate the issue?

1) How many images you have in a grid? Is it possible to make a new collection of 5k or 10 k images and see if you are still facing  the same slowness issue while scrolling the images?
2)  There are two aspects while scrolling a grid , one is grid loading i.e. image thumbnail  and metadata loading and other one is grid scrolling, when you are actually moving through images. Are you facing slowness in both the areas? 

3) Is it possible to share a screen recording?

Can you share your feedback in comparison to 9.2?
There might be a little jerkiness/ stuttering but it should be better than 9.2. The speed at which you can scroll through 57k images via using "down arrow" and "up arrow" should be faster in 9.3 as compared to 9.2.
Let us know your observations on the same.

Thanks
Mayuri
Photo of Joseph Rivera

Joseph Rivera

  • 43 Posts
  • 2 Reply Likes
I've captured a video here of a 10k image grid. You can see that I am experiencing both slowness of loading the image thumbnail and stuttering and slowness while scrolling. Although it appears I was simply scrolling slowly here, I was consistently hitting the down arrow key about once per second. You can see when I grab the scrollbar and attempt to manually scroll, the performance is unusable as the grid stutters and chokes, jumping around awkwardly.

Thanks for your help!

Photo of Dean Arnold

Dean Arnold

  • 13 Posts
  • 5 Reply Likes
Hi Mayuri  & Joseph,

Here's a similar video I recorded and posted on a few other support threads, using my 2019 MacPro demonstrating the same issue. I also compare the same photos in LR-C and LR-CC.


Photo of Mayuri Jain

Mayuri Jain, Employee

  • 90 Posts
  • 36 Reply Likes
Thanks Joseph and Dean for the recorded video. 
Photo of Dean Arnold

Dean Arnold

  • 13 Posts
  • 5 Reply Likes
+1 Here on a MacPro 4k27" LG PR580X, 12 core etc. very slow scrolling in library grid, lags behind badly behind the mouse.

See Rikk's comments on https://feedback.photoshop.com/photoshop_family/topics/lightroom-classic-is-slow-on-macbook-pro-2019-with-i9

---------------

later... oh... "The mouse/trackpad scrolling improvements did not make it into the macOS version" as stated in the Adobe community post. I 'hope' that is true.
(Edited)
Photo of Bill

Bill

  • 266 Posts
  • 39 Reply Likes
Perhaps you need to switch to Windows? (tongue in cheek emoji) 
 
6-core Xeon (3.6/4GHz), 64GB of RAM, whole library with 1:1 previews, 36,000 images, Nvidia Quadro P2200, BenQ PD3200Q 32" 4K monitor, Dell P2715Q 4K monitor. 
 
Don't see an improvement but then, it was instantaneous before. I run Lightroom full screen on either of the monitors. 
 
Maybe you need to spend $600 on those $20 coaster wheels? 
  
Photo of Joseph Rivera

Joseph Rivera

  • 43 Posts
  • 2 Reply Likes
LOL — I forgot the wheels, that’s it!!!
Photo of Joseph Rivera

Joseph Rivera

  • 43 Posts
  • 2 Reply Likes
I’ll actually boot over into Windows in boot camp to see what it’s like there. I have a feeling Apple's AMD drivers are sub-par. Shocker.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7627 Posts
  • 1739 Reply Likes
In addition to Mayuri's suggestions and requests, can you try disabling any BenQ profiles and revert to a standard OS display profile and report back on how scrolling performs then?
Photo of Joseph Rivera

Joseph Rivera

  • 43 Posts
  • 2 Reply Likes
Thanks. I gave that a shot, but no improvement.