Photoshop: No pressure sensitivity on Monoprice tablet

  • 1
  • Problem
  • Updated 1 year ago
  • (Edited)
My tablet and pen work fine with any other program, but I really want to use Photoshop. It was working the other day, but now it isn't. There's a ! in a triangle under the size jitter option under shape dynamics. I just wanna draw. ;-; I'm using a Monoprice tablet.
Photo of Julia Evans

Julia Evans

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 3 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
Check with your tablet maker for driver updates.

On Windows 8 and up you should be using the Microsoft Ink API, which your driver should support.
On Windows 7 you need to use the older WinTab API, which your driver should also support.
Photo of Julia Evans

Julia Evans

  • 2 Posts
  • 0 Reply Likes
I updated the drivers and when I did, it began to work with the other programs, but there's still no change in photoshop.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 811 Reply Likes
Then you need to contact your tablet maker and see if they can figure out why their driver is not working correctly.
Photo of Sam Burkman

Sam Burkman

  • 1 Post
  • 0 Reply Likes
Leaving a reply here since I have the same issue on windows 10 with a Monoprice graphics tablet and resolved it. 
I followed the steps here (for a monoprice tablet display, but it resolved my no-pressure-sensitivity issue: https://forums.adobe.com/thread/1500227)

In case the link gets scrubbed, here is the content:

Photoshop CC 2014 changes stylus use to use Microsoft system API's, with these API's you need to have Windows Ink enabled. These API's give better stroke results and improve the out of the box experience for users using Windows tablet/convertible devices. If you want to go back to the old WinTab implementation of previous versions do the following:
 
Create a file that contains instructions to revert to the WinTab functionality.
 
Create a text file in a text editor such as Notepad.
Type in the following lines:
# Use WinTab
UseSystemStylus 0
Save the file as a plain text file named PSUserConfig.txt, and save the file into the Photoshop settings folder: C:\Users\[User Name]\AppData\Roaming\Adobe\Adobe Photoshop CC 2014\Adobe Photoshop CC 2014 Settings\.
To turn off the gestalt's functionality, delete the PSUSerConfig.txt file. Or, move it to a different folder if it doesn't contain any other commands, or change the lines so they read:
# Use Win8 native tablet support
UseSystemStylus 1


I had a folder for "Adobe Photoshop CC 2015" and "Adobe Photoshop CC 2015.15", so I put the file in both places (though it was already present in the first folder).

I hope this helps someone else in the future.
Photo of Arion Ryuu

Arion Ryuu

  • 1 Post
  • 1 Reply Like
For anyone having problems still, I found a fix that worked for me. I recently bought PS CC 2017 and had no pen pressure with my Monoprice tablet. I have PS CS2 and Sai and both worked fine with the pen pressure.
I found some stuff online about the drivers for various tablets not working in PS CC 2014 and up because of Windows Ink and the newer versions of PS CC had switched over to using it instead of the old WinTab.
Anyway, I simply uninstalled my tablet driver and restarted PS CC 2017 and my pen pressure is working now. You may have to plug your tablet back in before Windows will recognize it once the driver is uninstalled.

My laptop is running Windows 10 and I have Windows Ink enabled. So anyone still having problems, here's something else to try! I can't guarantee it'll work with tablets like Wacom (it's been many years since I've used one), but it's worth a shot :)