Photoshop: No shortcuts when PC set to Danish / Nordic keyboard

  • 3
  • Problem
  • Updated 3 weeks ago
  • Solved
  • (Edited)
I could not use Photoshop properly for months - without the keyboard shortcuts working. Imagine not having ctrl-z??? Or any other shortcut.

Last night I wasted 5 hours removing all Adobe and reinstalling a few times and cleaning with Adobes DOS tool for this. And piles of other stuff googling for solutions. With no luck.

Now it seems I found a workaround and in some way a hint for solving the problem? As I am Danish I use a Danish keyboard layout (English being the language for the PC, not Danish). Changing to English / English makes the shortcuts come back.

How to make it work with my Danish keyboard also? Previously it worked for like 20 years, so I know it is possible :-)

We have a few more letters in Danish, but also most special characters are in different places than on an English keyboard, so keeping English / English is not a solution.

Illustrator and other Adobe apps never showed this problem. 

Different physical keyboards also did not change anything.

My Win 10 is Version 10.0.18362 Build 18362... 

Photoshop 20.0.6

My physical keyboard on my Huawei laptop is "Nordic" (two keys change letters between three languages), the other two keyboards I use are Danish Apple numeric keyboards, one USB wired, one bluetooth.
Photo of Jense

Jense

  • 6 Posts
  • 2 Reply Likes

Posted 9 months ago

  • 3
Photo of David

David, Official Rep

  • 3602 Posts
  • 615 Reply Likes
Hi Jense,

Let me make sure that I'm understanding the problem that you're facing, ok?  You're running the English version of Photoshop on an English OS with a Danish keyboard, right?  If that's the case, then everything should already be working correctly.  Photoshop takes the character VALUE not location (unless your virtual layout claims a non-Latin alphabet), so if you want to do Undo, CTRL+Z should work fine, particularly since Z is in the same place on both layouts.  Just to be super-certain there was no bug, I just tested this myself and it works correctly.  What are you seeing?

Thanks,
David
Photo of Jense

Jense

  • 6 Posts
  • 2 Reply Likes
Hi David, 

Thank you so much for caring about my problems. 

Yes, you got it right!

Yes, it should work but it does not. Although it did for 20 years or more... You might say that I also tested it for 20 years, I am super-certain that it did work, and now I am super-certain that it does not. 

What I see is that in the taskbar it says "ENG". Pressing this gives me the opportunity to change between Danish and English keyboard (see my screenshot). Set to Danish keyboard I have no keyboard shortcuts in Photoshop. Set to English keyboard I do. All of this with the same physical (Nordic or Danish) keyboard. 


Photo of Jense

Jense

  • 6 Posts
  • 2 Reply Likes
NONONO!!! YESYESYES!!! 

It works. 

CRAZY!

It is beyond my comprehension how this works, I mean it already said Danish keyboard. But you are right David, this is what made it work. How on earth I or anybody else should be able to guess this beats me.

THANK YOU THANK YOU THANK YOU!

Very best regards Jense

(also wondering how this page is funded, thanks official rep David! - hope you get something for your brilliant work and knowledge)

EDIT: PS: Any way to mark this problem solved and mark the right answer, if so please do :-)
(Edited)
Photo of David

David, Official Rep

  • 3602 Posts
  • 615 Reply Likes
Happy to help, Jense.  Let us know if you need any more help and have a great day!

David
Photo of Rorro

Rorro

  • 2 Posts
  • 0 Reply Likes
This happens to me too. But with English keyboard.
I have 3 layouts: English (Europe)>English US, Spanish and Russian.

CTRL+Z works only with Spanish layout. It doesn't work with Russian (I don't care) and most importantly it doesn't work with English.

I also tried to put English (Europe) > English International and it didn't work either.

I use English (Europe) instead of English (US/UK) to get locale formats that I prefer (in Argentina we use day-month-year format instead of month-day-year).


Photo of David

David, Official Rep

  • 3602 Posts
  • 615 Reply Likes
Howdy Rorro,
That looks like a Windows dialog.  Which version are you running?  Win10, right?

Tell me about your setup, please.  My own machine is configured with all of these languages with no problem.  Y más, mi teclado es español de Argentina...!  I also regularly test the Russian shortcuts, which SHOULD map to the US English key locations.
What PHYSICAL keyboard are you using?  You realize that these layouts are virtual -- Spanish and English are basically the same in terms of letters, EXCEPT for Z, which leads me to believe you're using a Spanish layout (which works) but when you switch to English or Russian, you're still pressing the buttons in the SPANISH location and NOT the English/Russian location.  Does that make sense?
For instance, when you press CTRL+Z, where is your Z?  To the bottom left of the keyboard, next to SHIFT or between T and U above?
Let me know / digame,Thanks / Gracias,
David
p.s. -- de donde sos?  Tengo familia en Buenos Aires, Formosa, y Carmen de Patagones...8-)
Photo of Jense

Jense

  • 6 Posts
  • 2 Reply Likes
Hey Rorro,
Stick to David, I am confident he knows what he is doing. Not like me
;-)
Photo of Jense

Jense

  • 6 Posts
  • 2 Reply Likes
Hi Rorro,

As you would read above all this sh** beats me - all I can come up with right now is:

Why don't you try and make keyboard English (in stead of United States), so that the two are the same?

Best of luck!

J
(Edited)
Photo of Rorro

Rorro

  • 2 Posts
  • 0 Reply Likes
Hey Jense, 
There is no English (English), I have to choose the what kinda of English I want from a list of countries. The only one without country is the one called International, but that one doesn't work either. 
Photo of Jense

Jense

  • 6 Posts
  • 2 Reply Likes
Hi Rorro,
Listen to David, he knows what he is talking about, me, I'm just going for lucky punches... :-)
- and I listen to David!
BR Jens
(Edited)
Photo of David

David, Official Rep

  • 3602 Posts
  • 615 Reply Likes
Hey Rorro,
Formatting and Keyboards are distinct -- changing one should no effect on the other, so if that's what you ARE seeing, then you're actually changing some OTHER setting.
To change virtual keyboards on Win10 go to Settings > Time and Language > Region and Language Preferred Languages and click Add a Language, then choose your language from the list.  All you REALLY need is the keyboard layout.  The mechanic to switch between layouts looks like this and is at the bottom right of the UI:
Photo of Paul Wilson

Paul Wilson

  • 3 Posts
  • 1 Reply Like
Keyboard shortcuts for me are messed up and don't work half the time in latest version (English). So back to 21.0.3 once again. Sorry for the semi hijack but can't be bothered making my own thread that I won't respond to. Adobe can fix it if they want but I'm staying on 21.0.3 from now on as there's been no reason to update from it.
Photo of David

David, Official Rep

  • 3602 Posts
  • 615 Reply Likes
We're happy to fix keyboard shortcut bugs.  But we need to know precisely what isn't working.  So if you or someone else can fill us in, we can then go fix it.  I haven't noticed any shortcut weirdness in 21.1.2.

This sentiment applies to any bugs, really.  Let us know and we'll investigate, but you need to share specifics.
Thanks!David
Photo of Eli Jacob

Eli Jacob

  • 1 Post
  • 0 Reply Likes
Hi, I don't know if it is the right place to post, I haven't found another place, Anyway I have encountered the same problem in PS 21.2.0 , while in Hebrew keyboard under windows 10 64bit  the Modifiers keys like ctrl, alt, shift, etc. with any letter or number combination won't work. for example Ctrl J  won't work Or ctrl 0 won't work too and so on, I have to change back to English keyboard in order to use the short-keys properly, Ín applications like MS WORD there is no problem swapping between the keyboards ...  Thanks