Lightroom Classic: No 1:1 view

  • 1
  • Problem
  • Updated 7 months ago
  • (Edited)
With the latest LR CLassic CC update, every time I double click for 1:1 view, it goes into smaller picture instead. I have to click on the "embedded view" first before I can get 1:1. It wasn't like this before the latest update.
Photo of Jino Lee

Jino Lee

  • 8 Posts
  • 1 Reply Like

Posted 7 months ago

  • 1
Photo of Jerry Syder

Jerry Syder

  • 222 Posts
  • 109 Reply Likes
Hey Jino. Well you've mentioned Embedded view so not sure my advice would serve you. However, when in your normal view(Maybe "fit"), can you hit T(to make sure the toolbar at the bottom is shown), then, instead of clicking to zoom, use the slider to zoom to 1:1? After that, when you click to zoom, it should remember your last zoom option. If you don't see the zoom slider, make sure it's selected in the dropdown as per below:
Photo of Rob Sylvan

Rob Sylvan, Champion

  • 15 Posts
  • 14 Reply Likes
Where are you starting from exactly? I am unable to reproduce what you are experiencing.
Photo of Jino Lee

Jino Lee

  • 8 Posts
  • 1 Reply Like
Thanks Jerry and Rob. Perhaps I should rephrase my issue.

When I import my images under "Embedded & Sidecar", once all the images are loaded, under "Fill" or "Fit" window, the images are pixelated. Then when I double click to view as "1:1" the image became very small. In order for the image to load properly in all windows including 1:1, I need to click on the "Embedded View" (in Grid window, bottom right corner of the image), then only the image will load properly in both Fill, Fit and 1:1.

I've removed all the images and re-import into LR in "Standard" instead of "Embedded & Sidecar" so that I can get a properly loaded image in "Fit" or "Fill" window. Btw I'm using iMac 27" 5K monitor.

Thank in advance.
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 1511 Posts
  • 605 Reply Likes
Maybe I don't understand what you are saying, but I get the impression that you simply use the wrong action. If you are in loupe view, and you want to zoom in, you have to SINGLE click, not double click. Double clicking gets you back to grid view (small thumbnails). That has always been like this.
(Edited)
Photo of Jino Lee

Jino Lee

  • 8 Posts
  • 1 Reply Like
Nope, it's not double click, its single click.
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 1511 Posts
  • 605 Reply Likes
OK, but you wrote “every time I double click for 1:1 view“, so I had to check.
Photo of Jerry Syder

Jerry Syder

  • 222 Posts
  • 109 Reply Likes
Can you record and share a video so the engineers can see exactly what's happening? I don't use the Embedded workflow so limited on advice, sorry. Hopefully Rob or another can chip in
Photo of Jino Lee

Jino Lee

  • 8 Posts
  • 1 Reply Like
I've recorded the video but unfortunately I don't have any YouTube, Vimeo and etc so I can't upload here. No worries, I shall avoid Embedded & Sidecar for now. Thanks Jerry.
Photo of Rob Sylvan

Rob Sylvan, Champion

  • 15 Posts
  • 14 Reply Likes
Hmmm ... if you are in Fit or Fill view, then you only single click the photo to zoom to 1:1. Double-click zooms and returns to Fit/Fill. Or am I missing something?

It does sound as though the embedded thumbnail made by your camera is very small, so perhaps the Embedded&Sidecar workflow is not ideal for you? Alternatively, you could try shooting raw+JPG to see if that gives a larger embedded preview (as Lr might use the JPG as the sidecar thumbnail).
Photo of Jino Lee

Jino Lee

  • 8 Posts
  • 1 Reply Like
I noticed the magnifying glass (mouse over) shows "-" instead of "+" and hence when I click on the image, it became small instead of 1:1. But strangely that doesn't happened before the latest update and in Standard workflow. No worries, I'll avoid that for the time being.
Photo of Rob Sylvan

Rob Sylvan, Champion

  • 15 Posts
  • 14 Reply Likes
Are you clicking in the Navigator panel? I assumed you were clicking on the photo in the main work area. Perhaps that's why I am confused? Maybe I need more coffee. :)
Photo of Jino Lee

Jino Lee

  • 8 Posts
  • 1 Reply Like
LOL! I'm clicking on the photo in Library module and my files are big as I'm using a7rII. When I don't import in Embedded & Sidecar workflow, all is good as before the update. This strange phenomenon happens only when I import the photos in Embedded & Sidecar workflow. No worries Rob, thanks for you time to look into this. Cheers!
Photo of Todd Shaner

Todd Shaner, Champion

  • 1106 Posts
  • 357 Reply Likes
Sony, Olympus, and Fuji cameras don’t have full sized embedded previews. With a high resolution display the images will appear as you describe in Fit, Fill, and 1:1 Zoom view. More here:

http://blogs.adobe.com/sunil/2017/10/18/embedded-preview-workflow-in-lightroom-classic/
Photo of Jino Lee

Jino Lee

  • 8 Posts
  • 1 Reply Like
Thanks Todd and I understand that. The issue I'm facing is, in Library module, when I click on the image or the 1:1 tab (on the top left corner) to make it 1:1, it became a small image instead of 100%. It only happens when my workflow is in Embedded & Sidecar but not Standard. 
Photo of Todd Shaner

Todd Shaner, Champion

  • 1106 Posts
  • 357 Reply Likes
If your using a Sony, Olympus, or Fuji camera what you're seeing is expected behavior with Import Preview setting 'Embedded & Sidecar.' For example a Sony A7R II ARW file has a 1616 x 1080 embedded preview. If using a 2560 x 1440 display the 1:1 Zoom view will only fill ~2/3 of the screen (1616/2560). With higher resolution displays (4K, 5K) the image size will be even smaller at 1:1 Zoom view. Conversely if you choose Fit or Fill the 1616 x 1080 embedded preview is upscaled (to fit or fill the loupe size) causing a pixelated appearance. This is similar to viewing an image at 2:1 or higher Zoom view. The first time you edit a newly imported image file in the Develop module LR will automatically build a standard size preview when you switch back to the Library module.

You have two solutions as discussed at the link I provided:

1) Set your camera to shoot raw + JPEG. LR will recognize the JPEG sidecar file and use it when importing with 'Embedded & Sidecar' Preview Building selection. After you've edited the image files and the previews have been updated you can remove the JPEG files from the raw file folder as they are no longer used by LR.

2) Select 'Standard' in the Import module Build Previews selector. If you need to view the imported image files at 1:1 Zoom view BEFORE applying any Develop edits then you should select 1:1 in the Import module Build Previews selector.
Photo of Jino Lee

Jino Lee

  • 8 Posts
  • 1 Reply Like
Thanks Todd 
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1484 Posts
  • 467 Reply Likes
With 1:1 zoom level, Lr always shows the actual 1:1 pixels of the photo.

In the Fit/Fill view, the new behavior (since Lr 6.8?) is this: if the image size (in this case embedded JPEG preview image?) is smaller than the view size, it will scale the image up. One can tell it through the shape of the magnifying glass cursor. If it is a plus, that means 1:1 will zoom in. If it is a minus, that means the 1:1 will zoom out (actual image is smaller that the view size).
(Edited)
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1485 Posts
  • 468 Reply Likes
Here is a documented workaround if you want the Fit/Fill view to NOT zoom in on small photos. See https://feedback.photoshop.com/photoshop_family/topics/fit-to-screen-behaviour-has-changed-since-upg...
(Edited)
Photo of Todd Shaner

Todd Shaner, Champion

  • 1106 Posts
  • 357 Reply Likes
Thank you Simon. When the Fit/Fill change was first implemented I was just as confused as the OP Jino Lee. Good to know that there is a fallback procedure to revert the behavior. I don't have enough small image files to worry about it, but others may prefer to revert back as you've outlined. Much appreciated!