Lightoom: "Built-in Lens Profile applied" doesn't appear for Nikon Z lenses

  • 1
  • Problem
  • Updated 1 month ago
  • Solved
  • (Edited)
[Update: Several users have reported that "Built-in Lens Profile applied" doesn't appear in the Lens Correction panel for Nikon Z lenses until they reset LR's preferences. See below. --John Ellis]

There are no correction profiles in my lr classic cc. When does adobe add these profiles?
Photo of heinrich wohlleber

heinrich wohlleber

  • 6 Posts
  • 0 Reply Likes

Posted 1 month ago

  • 1
Photo of JEA

JEA

  • 353 Posts
  • 200 Reply Likes
When using the nikon z6 or z7 with a nikon z mount lens the lens profile is built-in.


Photo of heinrich wohlleber

heinrich wohlleber

  • 6 Posts
  • 0 Reply Likes
of course i use the 4/24-70 and the 4/14-30 on a Nikon Z6!

Sorry, but my LR-Classic 8.3.1 (camera raw 11.3) says : "No matching profile found" and when i give it the brand "Nikon", it shows me the profile of a 4/105 mm lens. when i open the list, there is no z-mount lens available.......
Photo of Just Shot Me

Just Shot Me

  • 324 Posts
  • 91 Reply Likes
Uncheck the option to "Enable Profile Corrections".
Then give it a few seconds and you will see this at the bottom of the Lens Corrections section.


And cling the i in the circle will bring up the info panel.

If you are working with JPG then the lens correction is Baked Into the camera created JPG file.
Photo of John R. Ellis

John R. Ellis, Champion

  • 4466 Posts
  • 1186 Reply Likes
To build on Just Shot Me's reply, see this help article about working with lens profiles and built-in lens profiles: 
https://helpx.adobe.com/x-productkb/multi/lens-profile-support.html
Photo of heinrich wohlleber

heinrich wohlleber

  • 6 Posts
  • 0 Reply Likes
Hi and thanks for your help. But it doesn't work - even when i reinstall LR.
I tried the same Raw-File with Photoshop and there in Camera Raw it works fine - like you all said.

But in LR i get this:



After enabling lens corrections, i get:



After choosing "Nikon" i get 



with all my older lenses it works absolutely correct.

It's really frustrating
Photo of Just Shot Me

Just Shot Me

  • 330 Posts
  • 94 Reply Likes
What is the EXACT version of LR you are using?
Please don't say newest or latest. Go to the help menu in LR and click on System Info. Post the exact version number.
Photo of Just Shot Me

Just Shot Me

  • 330 Posts
  • 94 Reply Likes
Are you using a German version?
Photo of heinrich wohlleber

heinrich wohlleber

  • 6 Posts
  • 0 Reply Likes
As mentioned before, i use LR 8.3.1 and its is a german version.
Photo of John R. Ellis

John R. Ellis, Champion

  • 4466 Posts
  • 1186 Reply Likes
There have been a couple of other reports about the message "Built-in Lens Profile applied" not appearing for Z lenses:

https://forums.adobe.com/thread/2600541
https://forums.adobe.com/thread/2619571 

The person in the first thread solved the problem by resetting LR's preferences: 
https://www.lightroomqueen.com/articles-page/how-do-i-reset-lightrooms-preferences/

(Sprinkling that magic fairy dust often fixes things when LR's user interface goes wonky.)

If resetting preferences doesn't help, upload a sample photo to Dropbox or similar and post the sharing link here. Then we can determine if this is a problem with LR in general or your installation in particular.
Photo of heinrich wohlleber

heinrich wohlleber

  • 6 Posts
  • 0 Reply Likes
Thank you John,
i also could solve my problem this way. After resetting Preferences, the built in profile is recognized.
have a good time and thanks to all others, who tried to help me.

Photo of John R. Ellis

John R. Ellis, Champion

  • 4344 Posts
  • 1155 Reply Likes
Glad you got it resolved. Others have reported that though the message wasn't being displayed, the built-in profile was still being applied. Regardless, it's a bug, and LR clearly has always had problems with its preferences -- users shouldn't have to reset them to fix bugs.
Photo of heinrich wohlleber

heinrich wohlleber

  • 6 Posts
  • 0 Reply Likes
Indeed