NIK Plugins Not Drawing Correctly

  • 1
  • Problem
  • Updated 3 years ago
A couple months ago I was having problems with the Map module in Lightroom and Windows 7.  As a way of fixing it I took the plunge and upgraded to Windows 10.  That is when my NEW problem began.

Anytime I try to launch a Nik “Efex” filter from within Photoshop the plugin doesn’t work properly.  There are several drop downs that don’t draw all the items correctly.  The place where the drop down item is located is responsive, but it is either blank or completely transparent.  I’ve worked with Nik support and I’m at an impasse now.  I’m hoping for some additional support here.

The problem appears to have been introduced with Photoshop v2015.1.x.  The plugins work correctly for any Photoshop version up to v2015.0.1.  If I launch the Nik software as standalone applications they work perfectly.  The issue ONLY appears when initiating the software via Filter > Nik Collection > {filter name}.

I’ve disabled GPU acceleration in both Photoshop AND the Nik plugin software, but it doesn’t matter because Photoshop doesn’t detect or even allow me to enable GPU acceleration.

I’m using an older Dell Latitude laptop with a first generation Intel HD graphics card.  The latest Windows 10 supported driver is v8.15.10.2990.  I tried to hack the last Windows 7 driver, v8.15.10.2993, onto the system but experienced the same results.  I read the following under the GPU FAQ (link):
Intel HD Graphics (first generation) cards are no longer being tested and are not officially supported in Photoshop.  Some GL functionality is available for these cards, but newer features may not work.
According to that article’s metadata it was published on 2015.12.23 but Photoshop v2015.1.0 was released on 2015.11.30, perhaps this was a retroactive posting?  What is more frustrating is that a pre-Windows 10 upgrade physical-to-virtual VMware Workstation snapshot of my laptop runs Photoshop v2015.1.x AND the Nik plugins flawlessly.  This is also listed as an unsupported configuration on the GPU FAQ as well.  I have a hard time understanding why this configuration would work in a VM (hardware inferior) but not on a physical workstation (hardware superior).

Here are some screen captures (Google Drive, webm video) I sent over to Nik Support to try to find a resolution:

Good –
https://drive.google.com/file/d/0B-_y_kWscEGVSTVyUnMwLU5EaWM/view?usp=sharing

Bad –
https://drive.google.com/file/d/0B-_y_kWscEGVQnRrdXJrUGxxT1k/view?usp=sharing

I realize that these videos show how painfully slow the software is on this older laptop, however I’m perfectly happy with the response in the “Good” video.

Ultimately, at this point I’m at a dead end and at my wits end for this issue.  I really don’t want to invest in a new workstation when I’m perfectly happy with the one I’m currently using, minus this one minor issue.  Additionally, I don’t want to revert and hold at v2015.0.1 just to continue utilizing this plugin.  I realize that this isn't technically a "Photoshop Problem", however I've already exhausted the support options at Nik.

Any help anyone can provide would be greatly appreciated!
Photo of Elvis Rowe

Elvis Rowe

  • 8 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 818 Reply Likes
You need to contact Google/Nik about this issue with their plugins.
Photo of Elvis Rowe

Elvis Rowe

  • 8 Posts
  • 0 Reply Likes
Thanks for taking the time to comment. I've already been in contact with Nik. I've worked with multiple technicians, and at this point my support options through Nik have been exhausted. I wouldn't be posting here otherwise. Also this behavior only started after a Photoshop upgrade so I thought perhaps a change in Photoshop could be a cause.

Maybe I'll get lucky and someone else will reply with some additional troubleshooting ideas.