Elements 10: New warning "require that Microsoft Internet Explorer 5.0 or greater be installed" after upgrade to Windows 10

  • 2
  • Problem
  • Updated 2 years ago
  • (Edited)
Since upgrading to Windows 10 I now get the following message when starting elements 10.

"Some feature of Adobe Photoshop Elements require that Microsoft Internet Explorer 5.0 or greater be installed. These features will not function properly without it."

Is this a compatability issue with windows 10 as I am using IE11 and what will this affect
Photo of Phil Murray

Phil Murray

  • 1 Post
  • 0 Reply Likes

Posted 2 years ago

  • 2
Photo of Robert Kip

Robert Kip

  • 5 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Elements 10 will not run after computer upgrade to WIN 10.

Upgraded computer to WIN 10 from WIN 8.1. Elements 10 features disappeared (layers) and message reappeared continuously that some features would be inactive unless version of Internet Explorer later than ver 5.0 was installed - latest ver. 11 was being used.

PS Elements was uninstalled with the intent to reinstall. What I was done was a complete uninstall, including removal of the registration (S/N) code to enable a reinstall, and then reinstallation would not work at all. NOTHING could be found anywhere in the convoluted, endless loop of suggestions that addresses this situation, which must be common with all the upgrading to WIN 10 going on.

Now I have nothing.