new Solid Color layer replaces selected empty (raster) layer (Pain point)

  • 2
  • Idea
  • Updated 9 months ago
Hi!

I assume this is a very old design of PS behavior.

When adding a new Solid Color adjustment layer while having an empty (raster) layer selected the Solid Color layer replaces the empty layer and takes over its name...

This is a small constant issue for me and I constantly forget to work around this to prevent it from happening so I end up with a new layer and a Solid Color to clip to it (ie. coloring line-art).

This doesn't really hinder me in doing my work but since the behavior seems so odd and brings some frustration, I would like to ask if this is one of those last quirks surviving the ages in PS or if this is something a lot of users use or prefer?

Thanks for your time and effort!
Photo of Erik Jakobsson

Erik Jakobsson

  • 27 Posts
  • 1 Reply Like

Posted 9 months ago

  • 2
Photo of christoph pfaffenbichler

christoph pfaffenbichler, Champion

  • 1530 Posts
  • 308 Reply Likes
How do you usually add the Solid Color Layer (shortcut, menu item, ...)? 
Because for the shortcut approach a Script-workaround seems possible (have the Script check the active Layer for content, if none exists lock it and unlock it again after the Solid Color Layer has been created). 

Other than that I, as a fellow Photoshop user, can say that while I have been aware of the behaviour it affects me too seldom to matter much to me. 
But it is a curiosity indeed and as the empty Layer’s name can override a name entered in the »New Layer«-dialog for the new Solid Color Layer it might actually qualify as a bug.