Lightroom: New external hard drive with the same name and missing files

  • 1
  • Question
  • Updated 3 years ago
  • Answered
  • (Edited)
Oh, Victoria, I hope you can help me! I've seen your replies to others but am not sure which applies to me. All was well in LR CC until I installed another external hard drive (and yes, I'm on a Mac). The problem may be that both drives are Seagate Backup Plus. I added 4TB on to the name of the original one, which has all the photos, so I could distinguish. This original 4TB has all the photo files, and LR previously saw it with all my files under the name without the 4TB appendage. The new drive (let's just called it Seagate) has nothing except my Time Machine backups. In the Folders panel in LR, the NEW drive (Seagate) looks like it has all the photos in it, albeit now with the ? next to all photosI I thought maybe because they're both Seagate Plus drives the Mac got confused. I tried changing the name of the 4TB to remove the 4TB part so it might see it again. Now that drive is greyed out in LR and it's still seeing what it was seeing before. I'm sorry if any of this is not clear, I know it's a mess. Help, please?

Note: This conversation was created from a reply on: Lightroom: External hard drives not displayed in my Library any longer..
Photo of Nicole Wilde

Nicole Wilde

  • 18 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4127 Posts
  • 1471 Reply Likes
Hi Nicole. I've split your thread off as that one was about a folder display bug.

I'm not quite following - could you add a screenshot of your Folders panel with the volumes opened up so I can see what you're seeing please?
Photo of Nicole Wilde

Nicole Wilde

  • 18 Posts
  • 0 Reply Likes
Hi Victoria. I know, it's confusing. I'll attach the screenshot here of the original drive the photos were on. It's the one I'm calling the 4TB. It's greyed out now, and the only reason you see any folders in there is because I was experimenting with bringing files back in. That wasn't going well as it would add photos in but not all that were actually available to add. I'll send another image separately of the other drive in the Folders section of LR.
Photo of Nicole Wilde

Nicole Wilde

  • 18 Posts
  • 0 Reply Likes
This is actually the new drive, but (maybe because the drive had the same name?) LR apparently thinks the images were in there--they never were, it's a new drive.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4127 Posts
  • 1471 Reply Likes
If I'm understanding you correctly, right-click on the Lightroom Central folder, choose Find Missing Folder and navigate to the correct current location for that folder.
Photo of Nicole Wilde

Nicole Wilde

  • 18 Posts
  • 0 Reply Likes
The Lightroom Central folder is listed under the new drive--the one that doesn't actually have any of the photos on it. In my first screen shot where you see the darkened Seagate Backup Plus Drive 4TB, that is the one that has the photos. Does that make sense? You're not actually seeing what's on it in LR though.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4127 Posts
  • 1471 Reply Likes
Which drive is Lightroom Central on in Finder? The 4TB one right? So do as I said and Lightroom should update to show it under the 4TB one.
Photo of Nicole Wilde

Nicole Wilde

  • 18 Posts
  • 0 Reply Likes
Yes, it's under the 4TB one in Finder. But I believe you meant right-click on the Lightroom Central folder while you're in LR, right? It's not showing up there.
Photo of Nicole Wilde

Nicole Wilde

  • 18 Posts
  • 0 Reply Likes
I know it seems bizarre! But if you look at the screen shots, the 4TB drive is dark and only has the two folders I was test importing. Is it necessary for LR to see all the drives I've got hooked up? Is there a way to delete that non-4TB drive (where it thinks the folders are, but they're not) and then just re-import everything into the 4TB one? Lot of work but I'm not seeing how else to do this?
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4127 Posts
  • 1471 Reply Likes
Look at the Seagate Backup Plus Drive in LR's Folders panel.

Directly underneath is the Lightroom Central folder.

Right-click on it, choose Find Missing Folder and navigate to the correct location of the Lightroom Central folder, currently on the 4TB drive. Press Choose.
Photo of Nicole Wilde

Nicole Wilde

  • 18 Posts
  • 0 Reply Likes
Okay, so you're saying it doesn't matter if in LR it's seeing the wrong drive, just use it anyway since the folders are already there?
Photo of Nicole Wilde

Nicole Wilde

  • 18 Posts
  • 0 Reply Likes
Okay, did it! That did bring them all back in under the 4TB folder, THANK YOU SO MUCH! There is still the other drive showing (which I don't need in there) plus one other external drive showing that I also don't need in LR, is there a way to get rid of those entire drives?
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4127 Posts
  • 1471 Reply Likes
Show me...
Photo of Nicole Wilde

Nicole Wilde

  • 18 Posts
  • 0 Reply Likes
Okay hang on...
Photo of Nicole Wilde

Nicole Wilde

  • 18 Posts
  • 0 Reply Likes
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4127 Posts
  • 1471 Reply Likes
Ok, there's still quite a number of photo records that point to the Western Digital drive (and probably the other one). Where are those folders stored now? Assuming you want to keep the work you've done on those photos, you'll do exactly the same process - right-click on the folder, Find Missing Folder and navigate to the correct location.
Photo of Nicole Wilde

Nicole Wilde

  • 18 Posts
  • 0 Reply Likes
Well, all the actual photos are stored on the 4TB drive. I do back the folder I call Lightroom Central up to the Western Digital drive, so really they ought to be identical most of the time. So I could delete the WD one from LR so as not to cause confusion? If so, how would I do that? I know how to delete folders but not drives (unless the drive goes away if I delete all its folders, I can do that).
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4127 Posts
  • 1471 Reply Likes
So if you go look for the Bits & Pieces folder under the 4TB drive in the Folders panel, does it show up there or not? And if it does, which version of it has your correct adjustments?

If you simply follow my previous instructions, assuming it'll let you do so, then when you update the last folder under the WD drive, that drive will disappear from the LR Folders panel.
Photo of Nicole Wilde

Nicole Wilde

  • 18 Posts
  • 0 Reply Likes
It does show up under the 4TB drive, everything does since I followed your previous instructions to show it where to look.

Under the WD drive, there is no Lightroom Central folder. If I try to update the Bits & Pieces folder there (pointing it to that folder on the 4TB drive) it asks if I want to combine the folders. I am fairly sure the right folder would be on the 4TB drive (that's where all the latest stuff is stored) but in LR it appears the Bits & Pieces folder has more items. I think that's just because it didn't import all of them into the 4TB one, possibly because it thinks they're already in LR (because they're on the WD drive)?
Photo of Nicole Wilde

Nicole Wilde

  • 18 Posts
  • 0 Reply Likes
Victoria I need to run out for a couple hours but I will check in when I return. Thank you again for taking the time to help me out. :)
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4127 Posts
  • 1471 Reply Likes
Hi Nicole

If you let it combine the folders, take a catalog backup first, just in case it doesn't work as you expect.

Or go back to my previous post and answer "So if you go look for the Bits & Pieces folder under the 4TB drive in the Folders panel, [...] which version of it has your correct adjustments? "