PHOTOSHOP: Need for Java SE 6 runtime for OS X 10.10 is requested. No Java works!

  • 2
  • Problem
  • Updated 5 years ago
  • (Edited)
Merged

This conversation has been merged. Please reference the main conversation: Photoshop CS5: Not working in Yosemite (Java Runtime)

"An unexpected and unrecoverable problem has occurred. Photoshop will now exit." This is the error reading when Photoshop is attempting to open. Before Yosemite yesterday, it would. After Yosemite the error is given. What can be done???
Photo of Donald Knapp

Donald Knapp

  • 5 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 2
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 853 Reply Likes
No, you don't need Java at all to run Photoshop.
Some old (CS3 to CS5) installers used Java, but none of the recent ones do.

First, we need more details:
What version of Photoshop?
What are the exact error messages?
Did you migrate the apps from another volume or machine?
Photo of Carlos Ramos-Mattei

Carlos Ramos-Mattei

  • 1 Post
  • 0 Reply Likes
I've got the same problem after I upgraded to Yosemite yesterday. I installed Java8 and still no success, maybe because that is not needed. I can run DW and ID today after upgrading. But there is something that isn't working with PS.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 853 Reply Likes
Again, Photoshop does not use Java in any way. Installing or upgrading Java won't help when Photoshop does not use Java in any way.

Is Photoshop crashing? Can we see the detailed crash report?

This conversation is no longer open for comments or replies.