Lightroom 5.3: Mysterious Date Used in File Renaming

  • 1
  • Problem
  • Updated 3 years ago
  • (Edited)
I used custom template to rename my LR 5.3 files as follows:



My assumption is that the Capture Date would be used in the file name. However, I am now seeing that at least some (maybe all) the file names are several hours off from the capture date, as you can see in this example below. The file name indicates a capture time of 3:26:54 and the actual Capture Date is 8:26:53, a difference of five hours behind the Capture Date.



In this next example, the difference is not five hours, but eight hours behind.



I have no idea where it could have pulled the date from for that file name as there is no metadata date that even matches the file name date. I considered that I might have changed the Capture Date manually *after* renaming the files, but I know I did not. I also verified that if i apply the same file renaming template to the same image, again, it still makes the same error.

Any ideas?
Photo of Jon

Jon

  • 6 Posts
  • 0 Reply Likes
  • frustrated

Posted 4 years ago

  • 1
Photo of John R. Ellis

John R. Ellis, Champion

  • 3382 Posts
  • 854 Reply Likes
[Late reply to an old thread, mainly for anyone else searching the forums.]

This is very similar to the long-standing folder-renaming bug reported here:

http://feedback.photoshop.com/photosh...

LR (at least on Windows) appears to be getting the capture time zone wrong when it does renaming. Some workarounds that others have used:

- Import via memory card rather than USB cable.
- Do the renaming after import with Library > Rename Photo.