Photoshop: My brush cursor is showing a cross instead of a circle (turn off CAPS LOCK)

  • 6
  • Problem
  • Updated 2 months ago
  • Solved
  • (Edited)
Merged

This conversation has been merged. Please reference the main conversation: Photoshop: Why are my Brushes and Clone Stamp tool a crosshair? (CAPS lock on)

While using the brush tool on a layer mask of a smart object...I get crosshairs instead of a circle. I can change the brush size with the bracket keys and the size changes on the options bar, but I see a constant sized crosshair while brushing across the image.
Photo of James Ribniker

James Ribniker

  • 12 Posts
  • 3 Reply Likes

Posted 7 years ago

  • 6
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
Which application?
Which OS?

In Photoshop: if CAPS LOCK is down, you normally see just the crosshair.
Of if the brush is too small, or if the brush is too big for the display.
Photo of David Bethell

David Bethell

  • 3 Posts
  • 1 Reply Like
Genius.
Photo of mick hill

mick hill

  • 1 Post
  • 0 Reply Likes
great
Photo of C.K. Reasons

C.K. Reasons

  • 1 Post
  • 0 Reply Likes
I was losing my mind trying to work that out. Thanks!
Photo of Koustav Roy

Koustav Roy

  • 1 Post
  • 0 Reply Likes
Thanks a lot ,it was the capslock issue i found. Thank you sir .
Photo of Μαργαρίτα Κωβαίου

Μαργαρίτα Κωβαίου

  • 1 Post
  • 0 Reply Likes
thank u so much!!!
Photo of James Ribniker

James Ribniker

  • 12 Posts
  • 3 Reply Likes
Hi Chris, I'm using CS5 with Windows 7. CAPS LOCK is not on and the brush size is neither too small or too large. After I flatten all the layers, the brush circle reappears.

Each smart object layer, and there are three or four, has been processed with Silver Effects Pro 2 as a smart filter.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
Ok, then it's possible you just have a bug in your video card driver or a plugin.

Have you tried turning off OpenGL drawing in Photoshop's preferences and reopening your document?

Have you tried disabling your third party plugins?
Photo of James Ribniker

James Ribniker

  • 12 Posts
  • 3 Reply Likes
I should add, Intel Quadcore with 8GB of RAM, running in 64-bit mode.
Photo of eno

eno

  • 5 Posts
  • 0 Reply Likes
My caps lock is NOT on, and I'm going crazy looking for my Photoshop to display the brush size (and shape)! It's only showing me the mouse cursor! HELP!! :(
I'm using CS6, Mac OS, Intel Quadcore 16GB RAM.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 764 Reply Likes
What version of MacOS?
Photo of eno

eno

  • 5 Posts
  • 0 Reply Likes
10.9.4
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 764 Reply Likes
Check for utilities or other applications running that might be overriding the cursor.
Photo of eno

eno

  • 5 Posts
  • 0 Reply Likes
Nope - I installed a whole set of new (free?) brushes that might be causing this problem, but I uninstalled them and the problem persists!
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14146 Posts
  • 1765 Reply Likes
If your Caps Lock key isn't enabled, what are you preferences for cursor set to?

Photo of eno

eno

  • 5 Posts
  • 0 Reply Likes
Exactly that! :( Seems like I've tired everything by now!
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14146 Posts
  • 1765 Reply Likes
Can you save a copy of your existing preferences (drag the folder to the desktop) and restore your prefs to see if the problem goes away? http://blogs.adobe.com/crawlspace/201...
Photo of eno

eno

  • 5 Posts
  • 0 Reply Likes
Thanks for all the help! I just shut down my comp and restarted it - now it's all good, thanks!
Photo of Kanay Lal Ray

Kanay Lal Ray

  • 1 Post
  • 0 Reply Likes
thanks .....................................!!!
Photo of Koketso Makhele

Koketso Makhele

  • 2 Posts
  • 0 Reply Likes
Okay I'm going nuts now instead of showing my brush size in the circle I literally have a brush as  a cursor exactly like the tool image on the tool box? How do I Change this, I'm using Windows 10 16GB Ram and this is Adobe CC? 
Photo of Koketso Makhele

Koketso Makhele

  • 2 Posts
  • 0 Reply Likes
Ok I Found it...Under Edit >> Preference >> Cursors... >> then change the "Painting Cursors" from Standard to Normal Brush Tip!!!


Thank you very much!!! 
Photo of Aneesh Ansari

Aneesh Ansari

  • 1 Post
  • 0 Reply Likes
Here is best answer.

ctrl + alt + Shift > double click and restart photoshop ENJOY :) 
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 764 Reply Likes
Resetting all of Photoshop's preferences is overkill when you just need to change a key or a single cursor preference.
Photo of Reynold Jaquet

Reynold Jaquet

  • 11 Posts
  • 1 Reply Like
My cursor is changing to an arrow when painting or selecting. Even in Refine Edge.
My cursor prefrences are set like shown above.
So I have to click on "Show Only Crosshair While Painting" which is not a good solution for precise painting or selectionning.
Oddly, this does not happen in PS CC2017
Photo of Reynold Jaquet

Reynold Jaquet

  • 11 Posts
  • 1 Reply Like
I also clicked on "Reset Preferences on Quit". Did not help either.

This conversation is no longer open for comments or replies.