Photoshop: My Text Won't Show Up On My Graphic....

  • 2
  • Problem
  • Updated 3 weeks ago
  • Solved
  • (Edited)
I have looked at all the tutorials, asked someone who is experienced in Photoshop, and they cannot tell me why, when I click on the horizontal Text button...choose a font, color and size...and the click on the picture upon which I want to place the text....but when I start typing, the text will not show up. It creates a layer on the lower right side with the word that I typed as the layer name....but the word will not show up on the graphic upon which I typed it. HELP!!!!
Photo of Mark Kremer

Mark Kremer

  • 11 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 2
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 853 Reply Likes
Which product are you using?
Which version?
Which OS version?
Photo of Mark Kremer

Mark Kremer

  • 11 Posts
  • 0 Reply Likes
I am using Photoshop....version 2014.2.2......OS is Windows 7
Photo of Vicki Gibson

Vicki Gibson

  • 8 Posts
  • 1 Reply Like
i FOUND MY SIMPLE SOLUTION...I HAD FORGOT TO PLACE THE LAYER ABOVE THE PHOTO, VISUAL I AM WORKING ON...Text does all it needs to do now....just checking to see if others have forgot that!LOL  Oh well....so many steps, can only remember so much stuff!LOL
Photo of Mark Kremer

Mark Kremer

  • 11 Posts
  • 0 Reply Likes
32 bit
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 853 Reply Likes
First try resetting Photoshop's preferences, or at least reset the text tool settings.
Photo of Mark Kremer

Mark Kremer

  • 11 Posts
  • 0 Reply Likes
I did both of those
(Edited)
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 853 Reply Likes
Go to the GPU maker's website, find the driver for your GPU model, download and install it.
Photo of Mark Kremer

Mark Kremer

  • 11 Posts
  • 0 Reply Likes
Do you mean CPU??
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 853 Reply Likes
No, GPU - your video card.
Photo of Mark Kremer

Mark Kremer

  • 11 Posts
  • 0 Reply Likes
I don't think mine is expandable, so I'm not sure I could update it. However, for the record, the program worked for the first two weeks I had it. It just stopped working a couple of days ago.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 853 Reply Likes
No, you are updating the driver software for your video card, to pick up bug fixes made to that driver software.
Go to the GPU maker's website (will be Intel, AMD, or NVidia), get the driver update for your GPU mode, and install the update.
Photo of David

David, Official Rep

  • 3413 Posts
  • 567 Reply Likes
Hiya Mark,

If your text is appearing in the Layers Panel but not in the document, then there could be a couple of things going on.  Chris is talking general issues with your video card.  It could also be that your text layer is incorrectly set and/or your text is appearing "behind" some other layer in your document.

STEP ONE -- I would suggest going to your Layers Panel and making sure that the layer with the text is set to 100% Opacity and 100% Fill, that its visibility is set to ON (the eyeball is visible to the left of the layer), and that the blending mode (to the left of Opacity) is set to "Normal".  

If that doesn't fix things then try...

STEP TWO -- hold down CTRL and double-click the THUMBNAIL of your text.  What happens on screen?

Thanks,
David
Photo of JaNahn Barnhouse

JaNahn Barnhouse

  • 1 Post
  • 0 Reply Likes
It says "No pixels are more than 50% selected. The selection edges will not be visible." My opacity and fill are at 100% and it says normal. The layer is at the top....
Photo of David

David, Official Rep

  • 3096 Posts
  • 481 Reply Likes
It sounds like you're trying to make a selection before adding text.  You can't do that.  Just activate the Type tool by pressing T (or the correct icon in the Toolbox) and then click in your document where you want to add your type.  That's it.
Photo of Paul Harrison

Paul Harrison

  • 1 Post
  • 3 Reply Likes
the most common reason for this is you are choosing a text size that is too big for the area selected.
Photo of c

c

  • 1 Post
  • 0 Reply Likes
Yup!  Fixed my problem!  Thank you
Photo of Louisa Richardson

Louisa Richardson

  • 1 Post
  • 0 Reply Likes
You are correct! Thank you so much. Been driving me nuts for at least 30 minutes.
Photo of Meagan Pulliam Waite

Meagan Pulliam Waite

  • 1 Post
  • 1 Reply Like
Fixed mine, too!
Photo of Leah Waldner

Leah Waldner

  • 1 Post
  • 0 Reply Likes
HERO.
Photo of Anis Aous

Anis Aous

  • 1 Post
  • 0 Reply Likes
My hero 
Photo of Maheroshkof Zou

Maheroshkof Zou

  • 1 Post
  • 0 Reply Likes
I have the same problem ... when i write the text does not shown .. even its the top layer.. until i do zoom in or out to whole pic it shown...!!
Photo of David

David, Official Rep

  • 3096 Posts
  • 481 Reply Likes
Can you include a screenshot, preferably including your Layers panel.  It sounds like something is just set up wrong.

Thanks,
David
Photo of Angel Ôô

Angel Ôô

  • 1 Post
  • 0 Reply Likes
Same problem :(
Photo of David

David, Official Rep

  • 3096 Posts
  • 481 Reply Likes
Angel, have you tried to reduce your font size to a much smaller number?  If you're running a recent release, you should see placeholder text (Lorem Ipsum).  If you cannot, then your font size is too large.

Thanks,
David
Photo of Andrew Benninghoff

Andrew Benninghoff

  • 1 Post
  • 1 Reply Like
I had a similar problem that made no sense. I would type away and nothing would appear. I would check and make sure all of the rookie mistakes weren't being made (i.e. opacity, layering, etc.). I was finally messing around and found the issue. If you take a look at my attached screen grab, when I couldn't see my text, there were blank values in a lot of these fields instead of 0's. Once I went through and plugged in a value for each (particularly the one circled in red), suddenly my text showed back up. Maybe I accidentally hit a hotkey or something that caused a blank value to be inserted in the first place because I never touch the baseline shift (or maybe it was a weird bug), but this fixed my issue.
Photo of David

David, Official Rep

  • 3346 Posts
  • 545 Reply Likes
When in doubt, you can always go to the Character Panel's flyout menu and simply click Reset Character.  Everything returns to default.

Hope that helps,
David
Photo of Victoria Dunlop

Victoria Dunlop

  • 1 Post
  • 0 Reply Likes
Thank you so much! This fixed my problem!
Photo of Vicki Dvorak Copeland

Vicki Dvorak Copeland

  • 2 Posts
  • 0 Reply Likes
I use Photoshop Elements 6.0 and had the same problem.  I fixed it by clicking on the AA (anti-aliased) button to the right of the font size selector.  I apparently had activated it accidentally.  My text appeared and I was able to resize it without having it disappear!
Photo of Emily

Emily

  • 2 Posts
  • 0 Reply Likes
I have tried everything written on this page to trouble shoot this issue. When I work on other projects I have started a few days ago I have no issues typing on those. When I am trying to work on new projects the type face wont show. I have tried EVERYTHING, and I am at the point of wanting to throw my computer at a wall. 
Photo of David

David, Official Rep

  • 3169 Posts
  • 500 Reply Likes
Howdy Emily,

Well, please don't toss your machine at the wall.  I'm sure we can figure this out.

First, are you using Photoshop?  Which version?  On what kind of computer?  Running which operating system?

Next, what kind of graphic are you working with?  And you're sure that the Type layer is above your graphic layer in the Layers panel / layers stack?  And you are using the regular Type tool?

Let's start with that and work forward.  I'm also available for a web-hosted screenshare which would be a super fast way to get you working again.

Thanks,
David
Photo of Emily

Emily

  • 2 Posts
  • 0 Reply Likes
HI David, 

I have the newest verison of Photoshop. I just started with my company so they got me the newest of the new that they could, so its the 2018 version. I am using a Dell, and I am not sure of the operating system but it says "OptiPlex3040" I hope that helps. 

Yeah I went to school for art and took some graphic design classes so I know the basic things to look for with this issue. I am currently working on a 210" by 20" Escalator ad. But yes the type is on the top layer, it is on visible, opacity and all of that jazz is 100% and normal. I am using the regular type tool as well. I tried even resetting the type character. It's strange that I can write on all my older documents except anything new that I have created. 

Emily
Photo of David

David, Official Rep

  • 3169 Posts
  • 500 Reply Likes
Good Morning, Emily,

If you're running a new Dell, then you're on some version of Win10.

Could you either post a screenshot from Photoshop or send me the file (my email is <my first name> (dot) mohr <at> adobe (dot) COM) or could we do a web-hosted screenshare?  That way I can see (and possibly interact with) this file and get you working quickly.  For the screenshare, all you need is a phone line (the number is toll free from every country I've tried in the last 20 years!), modern browser (Chrome works best), and internet connection.  You'll probably be asked to install the Adobe Connect plugin, but that's not a big deal and takes only a few seconds.

Let me know and we'll get this working again for you...

Thanks,
David
Photo of Vicki Gibson

Vicki Gibson

  • 8 Posts
  • 0 Reply Likes
 I am having the same problem. I have been trying to put text onto some shapes but al lI get is a  line with no text on it.  It was working fine with the rest of my layers, but not this one. Will do invisible text or the line if put into a text box...like sheesh!  I have all the updates, etc, photoshop cc....sigh...back at it...!
Photo of Vicki Gibson

Vicki Gibson

  • 8 Posts
  • 0 Reply Likes
Hey found simple solution...don't forget to place you typing layer ABOVE the layer you are putting it on...whew!!!:)  Simple layer placement .....of course....! SiLLLY ME!!
Photo of Zarah May

Zarah May

  • 1 Post
  • 0 Reply Likes
My photoshop is not letting me text and when I zoom in it is typing tiny blobs. I reset my text, opened a new page, added blank layers. I dont know what is going on, any advice?
Photo of David

David, Official Rep

  • 3096 Posts
  • 481 Reply Likes
Hi Zarah,

Have you tried changing the font and point size that you're using?  What resolution are you working at?

Thanks,
David
Photo of Nick Ryan

Nick Ryan

  • 1 Post
  • 2 Reply Likes
Check to make sure your margins from a previous project aren't preventing space for your text


Photo of Jason Curtis

Jason Curtis

  • 1 Post
  • 0 Reply Likes
Just downloaded the newest version of Photoshop.  Text wasn't showing up from the very beginning with nothing above fixing the issue. I went to the Character Panel's Flyout Menu.  I had to 'reset paragraph'. For some reason the 'Hyphenate' button was clicked.  Once that was unclicked, I was good to go.


(Edited)
Photo of Celeste Michaelson

Celeste Michaelson

  • 1 Post
  • 0 Reply Likes
I'm experiencing this same issue and have tried everything listed above.  My layer is in the correct spot, I reset both my character and paragraph panels, the opacity and fill are both at 100% and next to opacity is set to 'normal.'  I tried changing the font size, restarting my computer, and restarting photoshop and nothing has worked.  Anyone else have this issue?
Photo of David

David, Official Rep

  • 3390 Posts
  • 558 Reply Likes
Howdy Celeste,

Okay, you might have tried all this, but just bear with me.

First, bring your layer to the top of the layer stack.  Can you see it now?  What's its blend mode?  Set it to Normal just to be sure.  Also, set both Opacity and Fill to 100%.  If you cannot see it now, then there's a problem with the CONTENT of the layer, rather than it being blocked by something else.  Another way to see if a given layer contains something would be to CMD/CTRL+click on the layer thumbnail in the Layers Panel -- you should see a selection of "marching ants" around the edges of the content (and that even works with text).  Next step...

Second, this is text, right?  And you have the font on your machine, right?  Set the point size to something really small like 6pt, making sure that the Paragraph Panel is reset and the bounding box is large enough to accommodate the text.  Make sure the color isn't white or whatever your background color is.  Try bright pink or purple or green.  If that still isn't working, you might have something "funky" going on...

If you're still having problems at this point, yeah, something might be weird.  Trash your PS preferences and create a new (RGB) document with a white background.  Thanks to trashing your prefs, you should now have black, Myriad Pro, 12pt type.  Click once in the document with your Type tool active to create Point Text.  Now you really should see lorem ipsum (even if you disabled it before, cuz you trashed your prefs, it should be back).  If you don't something CRAZY is happening and you should write me here.  Otherwise, you should have text working now and you can use that to figure out what went wrong in your other file.  Make sense?

Thanks,
David
Photo of PECourtejoie

PECourtejoie, Champion

  • 845 Posts
  • 305 Reply Likes
Stunning answer, David, as always! Adobe is lucky to have you!
Photo of yue hwee

yue hwee

  • 1 Post
  • 0 Reply Likes
Hello,

May I ask, do you know why text might appear on a white background but not in front of a photo? I've followed your instructions already but it still can't be seen.

Thank you
Photo of David

David, Official Rep

  • 3390 Posts
  • 558 Reply Likes
Howdy Yue,

If you're not seeing text that's has a color of black, make sure that the layer with the type is above the other layers AND make sure that the layer's blend method is Normal.  I'd be willing to bet that your blend method is off...

Thanks,
David