Lightroom for mobile: What versions of Android are supported?

  • 1
  • Question
  • Updated 4 days ago
  • Answered
  • (Edited)
my old android tablet runs on kit kat 4.4 ,cannot get lightroom cc updates.I am on subscription  model,On my android smartphone its fine and i get update notifications.
is it cos of old hardware /OS ..i wonder?
Photo of Vijayan Menon

Vijayan Menon

  • 2 Posts
  • 0 Reply Likes

Posted 5 days ago

  • 1
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5353 Posts
  • 1113 Reply Likes
Please see: https://helpx.adobe.com/mobile-apps/help/lightroom-mobile-faq.html

Lightroom Mobile requires 5.x or later (lollipop)
Photo of Vijayan Menon

Vijayan Menon

  • 2 Posts
  • 0 Reply Likes
Thanks...thought as much