Lightroom CC: (Installed on Sierra) doesn't detect the latest update, why?

  • 1
  • Problem
  • Updated 2 years ago
  • Solved
  • (Edited)
On my Mac desktop the Lightroom update is regular (now has 6.7/2015.7) on my MacBook can't take over the last version. Both are OS Sierra, any idea or solution about?
I installed and uninstalled several times and I have a regular membership.
Photo of Antonio Ficai

Antonio Ficai

  • 6 Posts
  • 0 Reply Likes
  • exhausted

Posted 2 years ago

  • 1
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4393 Posts
  • 1604 Reply Likes
When you say the MacBook can't take over the last version, what happens when you try?
Photo of Antonio Ficai

Antonio Ficai

  • 6 Posts
  • 0 Reply Likes
nothing, in Creative Cloud pop-up my Lightroom results updated but the version is 2015 not the last 2015.7 as on my desktop, I don't understand why
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4393 Posts
  • 1604 Reply Likes
So just to confirm, if you open Lightroom on that computer and go to Help menu > System Info, it says Lightroom CC 2015.0 at the top of that dialog too?
Photo of Antonio Ficai

Antonio Ficai

  • 6 Posts
  • 0 Reply Likes
yes :(
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4393 Posts
  • 1604 Reply Likes
Ok. And if you click in the cog icon in the top right corner and choose Check for Updates, the Update button doesn't become available?

And you've tried uninstalling and reinstalling... just Lightroom, or CC too?

The nuclear solution is the CC Cleaner Tool, and it almost always works. Just have to make sure you've backed up all your presets and plug-ins etc. before running it, so make sure you read the instructions carefully.  https://helpx.adobe.com/creative-cloud/kb/cc-cleaner-tool-installation-problems.html

Or you could try installing the 6.7 patch from this page: https://helpx.adobe.com/lightroom/kb/lightroom-downloads.html
Photo of Antonio Ficai

Antonio Ficai

  • 6 Posts
  • 0 Reply Likes
Victoria I've tried all solutions you write, I use this forum as last chance to solve the problem
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4393 Posts
  • 1604 Reply Likes
A long shot then... have you tried creating a second user account, and seeing if it'll install that way?
Photo of Antonio Ficai

Antonio Ficai

  • 6 Posts
  • 0 Reply Likes
no, now I'll try and I'll let you know
Photo of Antonio Ficai

Antonio Ficai

  • 6 Posts
  • 0 Reply Likes
OK Victoria with your tip now it works! 
I've created a new account on my laptop, installed Creative Cloud, login with my Aobe account and installed the right version of Lightroom, finally after two weeks I can relax.
Thank you very much :D
(Edited)
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4393 Posts
  • 1604 Reply Likes
Wonderful news. There must be something going on with your original user account, although I would have expected the CC Cleaner to find it.