Lightroom Classic: Erratic Behavior When Using Multiple desktops

  • 3
  • Problem
  • Updated 6 days ago
  • Solved
  • (Edited)
I use LR7 Classic on a MacBook Pro with multiple desktops, running different apps on different windows. When i open LR they go crazy, frantically switching between desktops. It takes ages to catch LR in time to shut it down so I can return to normal. I then have to close all other apps if I want to use LR!!
Photo of Dave Roberts

Dave Roberts

  • 150 Posts
  • 25 Reply Likes

Posted 1 year ago

  • 3
Photo of Rick Spaulding

Rick Spaulding, Champion

  • 564 Posts
  • 231 Reply Likes
Hi Dave,

As a start you could try resetting preferences. Just hold down Alt / Shift (Win) or Option / Shift (Mac) while opening the app from the Creative Cloud desktop app then choose "Reset Preferences" 

Let me know if that helps.

Also, if that doesn't help, please share the version of your operating system and the version of Lightroom your are using.

Rick
(Edited)
Photo of Dave Roberts

Dave Roberts

  • 150 Posts
  • 25 Reply Likes
Thanks, I  have reset preferences and will test it out, it is/was not consistent other than it only happens with certain combinations of apps running but LR was always one of them.

Dave
Photo of Dave Roberts

Dave Roberts

  • 150 Posts
  • 25 Reply Likes
I have tried this and been running LR again today, it is still the same, LR flashes between screens and you have to not touch a mouse or keyboard until it settles and then hopefully you get back control, but not always first time.
Photo of Rick Spaulding

Rick Spaulding, Champion

  • 564 Posts
  • 231 Reply Likes
Official Response
I did some digging around and came up with this about using Mission Control. Let me know if this helps...

1. Right click the Lightroom icon in the Dock and choose Options > None, like this:



2. Make sure the other open applications are set to None. (they should be by default)

3. Open System Preferences and choose Mission Control

4. Uncheck "Automatically rearrange Spaces based on most recent use" like this:



See if that makes the behavior stop. If not, go back and assign a Desktop to the Lightroom application. To do this:

1. Put Lightroom on an open Desktop 

2. Right click the Lightroom icon in the Dock and choose Options > This Desktop 

Let me know if that helps.

Rick
Photo of Michael Ingmanson

Michael Ingmanson

  • 1 Post
  • 0 Reply Likes
Rick - Your second suggestion seems to mask the big I was seeing too. Anytime I switched modules I would be automatically kicked to another desktop [super anoying]. You can see the behavior here - https://youtu.be/flGqGKmVETE

So far this seems to resolve the issue. 

Thanks, 
-Michael
Photo of Dave Roberts

Dave Roberts

  • 150 Posts
  • 25 Reply Likes
Thanks Rick, I have been experimenting today and whilst the 1st of your suggestions was not relevant as this was the case for my settings anyhow, the second so far has worked. If you don't hear further assume all is well and thanks.

Dave
Photo of Rick Spaulding

Rick Spaulding, Champion

  • 564 Posts
  • 231 Reply Likes
Good to hear, Dave. I'll bring this up with our engineers and try to suss out whether it's a Lightroom or Apple issue. 

Cheers!
Photo of Steve Palmer

Steve Palmer

  • 4 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Lightroom Classic on Mac OS 10.13 - Going into Develop module flicks to new Deskt....

When I go into Lightroom and use shortcut D to go into the develop module the desktop changes away from Lightroom.  When I move into Library mode the same happens.  This has happened over several days and over several reboots.  
Photo of Dave Roberts

Dave Roberts

  • 150 Posts
  • 25 Reply Likes
See Ricks reply, his second suggestion seems to be working for me!

1. Right click the Lightroom icon in the Dock and choose Options > None, like this:

Image https//d2r1vs3d9006apcloudfrontnet/s3_images/1689986/RackMultipart20180107-98753-1a9ye0s-Screen_Shot_2018-01-07_at_45748_PM_inlinepng1515365935

2. Make sure the other open applications are set to None. (they should be by default)

3. Open System Preferences and choose Mission Control

4. Uncheck "Automatically rearrange Spaces based on most recent use" like this:

Image https//d2r1vs3d9006apcloudfrontnet/s3_images/1689990/RackMultipart20180107-91239-1pswa2y-Mission_Control_inlinepng1515366485

See if that makes the behavior stop. If not, go back and assign a Desktop to the Lightroom application. To do this:

1. Put Lightroom on an open Desktop

2. Right click the Lightroom icon in the Dock and choose Options > This Desktop

Let me know if that helps.
Photo of Mark Whitelock

Mark Whitelock

  • 4 Posts
  • 0 Reply Likes
I have this issue also and will try the work-around, but this isn't a fix as I do not have to do this workaround for any other application on Mac OS and changing a global setting in Mac OS for the sake of LR Classic CC indicates a bug to be resolved in LR.

This issue is still present in the most recent LR Classic CC (as of 5th May 2018).  It usually use this on my iMac which has a fixed multiple screen, however, currently i'm using LR on a MacBookPro with a temporary 2nd screen and have the same issue.  I'll lock LR to the 2nd screen as it has a higher resolution.

For me these are the issues I have on both my iMac and MacBookPro.
  • Multiple screen setup.  The resolution of the screens do not match. 
  • LR will spontaneously switch from one monitor to another.
  • With multiple desktops, returning to LR will rapidly switch to another desktop.  e.g. if LR is on desktop 2 with Safari on desktop 1 (full screen), as perform the gesture to swipe to LR, LR instantly causes the desktop to switch back to Safari.  (I'm using Safari as an example, it can be any alternative desktop on the same monitor.)  As the original post mentions, you have to be extremely quick to catch LR and close it.  Sometimes I find hit F to switch the screen mode in LR resolved it. 

If there is any other information I can supply to help track the bug let me know.
Photo of Mark Whitelock

Mark Whitelock

  • 4 Posts
  • 0 Reply Likes
Locking to a specific desktop doesn't work for me with the latest release.  What I have noticed is if you swipe up on the trackpad to see all windows/switch windows, the LR window width is completely wrong.  Much wider than it should be when looking at the blue highlight frame.   I wonder if this is an indication on what is causing the issue.

Photo of Matt Fresco Dealy

Matt Fresco Dealy

  • 1 Post
  • 0 Reply Likes
I have this same issue. It has been plaguing me nearly a year now. I finally got so fed up with it today that I found this forum. Its pretty sucky that we have to lock lightroom to a certain desktop. It is definitely a lightroom issue because I have never had this problem with any other applications. It seems like lightroom just thinks it is locked to one of my desktops even though it is not. It is really annoying. I have it locked to a single desktop now but that means every time I use it I will have to lock it to whatever desktop I open it on which is just another step to remember.