Photoshop: Logitech mouse scroll wheel do not change input fields correctly

  • 1
  • Problem
  • Updated 6 years ago
  • Solved
  • (Edited)
Hi guys,

Some general info:

1. I have Logitech Keyboard K800 - it have its own receiver

2. I have Logitech Mouse (MX1100) - it have its own receiver

3. Photoshop CS6 x64 - latest updates

4. Windows 7 x64 - latest updates

5. SetPoint - latest version

6. More about the system (please let me know if I have to post all the text from Photoshop System Info popup):

Adobe Photoshop Version: 13.0.1 (13.0.1 20120808.r.519 2012/08/08:21:00:00) x64

Operating System: Windows 7 64-bit

Version: 6.1 Service Pack 1

System architecture: Intel CPU Family:6, Model:10, Stepping:7 with MMX, SSE Integer, SSE FP, SSE2, SSE3, SSE4.1, SSE4.2, HyperThreading

Physical processor count: 4

Logical processor count: 8

Processor speed: 3410 MHz

Built-in memory: 16342 MB

Free memory: 9098 MB

Memory available to Photoshop: 14718 MB

Memory used by Photoshop: 90 %

Image tile size: 128K

Image cache levels: 4

OpenGL Drawing: Enabled.

OpenGL Drawing Mode: Advanced

OpenGL Allow Normal Mode: True.

OpenGL Allow Advanced Mode: True.

OpenGL Allow Old GPUs: Not Detected.

Video Card Vendor: NVIDIA Corporation

Video Card Renderer: GeForce GTX 560/PCIe/SSE2

Display: 1

Display Bounds:= top: 0, left: 0, bottom: 1050, right: 1680

Video Card Number: 1

Video Card: NVIDIA GeForce GTX 560

OpenCL Version:

Driver Version: 9.18.13.1090

Driver Date: 20121229000000.000000-000

Video Card Driver: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um

Video Mode: 1680 x 1050 x 4294967296 colors

Video Card Caption: NVIDIA GeForce GTX 560

Video Card Memory: 1024 MB

Video Rect Texture Size: 16384

Serial number: 92298292820550253494

Application folder: C:\Program Files\Adobe\Adobe Photoshop CS6 (64 Bit)\

Temporary file path: C:\Users\kckfm\AppData\Local\Temp\

Photoshop scratch has async I/O enabled

Scratch volume(s):

F:\, 685.6G, 198.8G free

Required Plug-ins folder: C:\Program Files\Adobe\Adobe Photoshop CS6 (64 Bit)\Required\

Primary Plug-ins folder: C:\Program Files\Adobe\Adobe Photoshop CS6 (64 Bit)\Plug-ins\

Additional Plug-ins folder: not set

Some other info:

You know that you can control Photoshop input fields http://screencast.com/t/ApVseKYRxz with the mouse scroll wheel. Pretty handy indeed. You just have to click on the field and spin the wheel and values changing.

The problem:

My mouse wheel cannot control the input fields in this way. I select the field, spin the wheel and nothing happen. When I spin it faster a couple of times, than the values get changing - pretty strange ha? Scrolling normally - do not change, scrolling fast change. But to scroll fast is not an option because I cannot change the values slightly with small increments... There is a bug really...

What I tried and didn't work:

1. Restarted Photoshop

2. Plug/Unplug and change different USB slots for both receivers.

3. Reintalling latest SetPoint Drivers (after uninstall I run ccleaner)

4. Put all SetPoint settings to defaults (because I programmed some mouse keys to Photoshop specifically).

5. Install earlier versions of SetPoint drivers.

6. Set my UEFI BIOS to defaults.

7. Restarted the BIOS to load all the drivers again, but still no luck

(the last think I didn't do is to reinstall Photoshop)

What I have investigated so far:

1. When I restart the computer and run Photoshop it works perfect HA! , but after a seconds it do not words again ...

2. When I stop SetPoint software, when I shut down it, it words perfect.

3. When I unplug keyboard receiver it words perfect, but I do not have keyboard:)

4. Everything works perfect in Illustrator and After effects.

5. Also I noticed that when I scroll images in CameraRaw - http://screencast.com/t/xKnn6cY9 the I have to scroll harder and spin the wheel harder to scroll - the same problem.

6. Also in photoshop and bridge scrolling here - is pretty smooth and works perfect - http://screencast.com/t/75IXMG6Zria

Maybe the most important part - When I start experiencing the problem:

I had same configuration , same everything and everything worked fine.

I installed SSD disk, reinstalled Windows (same like before), updated my BIOS to UEFI. Installed Photoshop and SetPoint and problem started.

Posted same request to Logitech, but want to ask you for help too.

Thanks!
Photo of kckfm

kckfm

  • 35 Posts
  • 2 Reply Likes

Posted 6 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 818 Reply Likes
That just means that the SetPoint driver software has a bug.

We've seen a lot of bugs in Logitech's drivers, and most of us just run logitech devices without their extra drivers.
Photo of kckfm

kckfm

  • 35 Posts
  • 2 Reply Likes
Hi Chris,

Thanks for the fast reply.

I mapped lots of the mouse buttons to help me use photoshop. Do you know any other way to map my mouse button without SetPoint?

Thanks!
Photo of kckfm

kckfm

  • 35 Posts
  • 2 Reply Likes
Hi all,

I found a solution.

1. Uninstall your current Setpoint Driver.
2. Run CCleaner - http://www.piriform.com/ccleaner
3. Download an older version of SetPoint - http://www.oldapps.com/setpoint.php
(I used SetPoint 6.15 (x64), I tried 6.20, 6.32, 6.50 , but no luck)
4. Now everything is all right!

Thanks!

Can somebody mark this as solved? Thanks!

SK
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14528 Posts
  • 1883 Reply Likes
Thanks. Marked solved. Thanks for closing the loop.