Photoshop CS4 crashing when dragging layers on Mountain Lion (MacOS 10.8)

  • 1
  • Question
  • Updated 6 years ago
  • (Edited)
On Photoshop CS4 Extended v11.0, working like a charm before the Mountain Lion update. Now anytime I try to drag a layer into the drag or option drag to duplicate. Crashed Every time. So far I haven't noticed any other bugs.

I tried repairing permissions but I still get the problem...
Photo of Leonardo Bodmer

Leonardo Bodmer

  • 6 Posts
  • 0 Reply Likes

Posted 6 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
What does the crash report say? (most likely still crashing due to the OS bug in QuickDraw, that Apple won't be fixing)
Photo of Leonardo Bodmer

Leonardo Bodmer

  • 6 Posts
  • 0 Reply Likes
Just installed Mountain Lion on my MacPro with 2x 2.8GHz Quad Core Intel Xeon and I don't get the drag layer crash which is great! Tried the exact same PSD file on both machines.

On my Laptop I am still getting the crash. I'm on a 2.53GHz Intel Core i5 MacBook Pro. The crash report is long, I sent it in to Adobe already about 3-4 times. Is there something specific I should be looking for?

Priority number, Thread number...

I tried rebooting preferences (option, command, shift at PS startup) and zapping PRAM as well, so far no luck.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
OK, sounds like you are hitting the graphics switching bug in QuickDraw (turning off automatic graphics switching will make it go away) -- that OS bug affects laptops with dual GPUs.
Photo of Leonardo Bodmer

Leonardo Bodmer

  • 6 Posts
  • 0 Reply Likes
Please post how to deactivate/turn off the Auto Switching for others that have the same problem. I can't locate exactly where that is myself. Thanks so much for your help pin pointing the problem!
Photo of Leonardo Bodmer

Leonardo Bodmer

  • 6 Posts
  • 0 Reply Likes
Actually found a link here. Please confirm that this is the correct setting we have to deactivate.

http://serato.com/video-sl/support/56...
Photo of Leonardo Bodmer

Leonardo Bodmer

  • 6 Posts
  • 0 Reply Likes
So far looks like that did the trick! no more crashing, hallelujah!
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
Yep, that's the one.
Photo of Leonardo Bodmer

Leonardo Bodmer

  • 6 Posts
  • 0 Reply Likes
FYI... for some reason the energy setting for graphics switching will default and turn back on when you restart, so make sure to LOCK the setting after you deactivate graphics switching.

Been working great, Thanks for resolving this issue!