Mojave Photoshop CC19: selections & transform control tools not showing

  • 3
  • Problem
  • Updated 1 year ago

This conversation has been merged. Please reference the main conversation: Photoshop CC 2019: I have no text cursor/highlight, no bounding boxes, or selection edges working on CMYK documents

I updated to MacOS Mojave last weekend, and now none of my selections are highlighted or outlined, and transform controls (the little boxes you can select to stretch or re-size objects) are no longer showing. I can guess where the control boxes are, and then resize objects, but it's hit and miss. Same for text selections; selected text is not highlighted but I can edit text by typing after guessing the selection.

For example, if I select a layer, select the move tool, make sure the "Show Transform Controls" is selected, there is no visual prompt in my edit window to show that any item is selected. Yet I can move the object (with no visual clues or guides for the selection), or I can select a corner by guessing where the small box selection would be, then scale or stretch the object. Again, other than the object changing shape, there are no guides or lines to show me bounding boxes, alignment to other objects etc.

I'm running Mac OS 10.14.1 and Photoshop CC 20.0.1. I've tried switching between Mojave light and dark modes, but this has no impact. I've also rebooted several times.

Help, this is a pretty fundamental problem; I'm running blind!


Photo of Gareth Noyes

Gareth Noyes

  • 7 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 3
Photo of eartho

eartho, Champion

  • 1522 Posts
  • 520 Reply Likes
view/show and/or view/extras
Photo of Gareth Noyes

Gareth Noyes

  • 7 Posts
  • 0 Reply Likes
Thanks eartho, but that's not the issue. Looks like this is a known problem: workaround is to open an RGB file first or turn off the GPU acceleration.

Photo of Silvia Gervasio

Silvia Gervasio

  • 5 Posts
  • 2 Reply Likes
I'm having the same problem, with any kind of layer/file. Transformation Controls not showing even though all the boxes are ticked.
I'm on Mac Mojave with the latest Photoshop CC 2019 installed. 

I tried all of the following:
  • Ticking / Unticking / Ticking again Show Transformation Controls: didn't work
  • Ticking / Unticking / Ticking again Show Extra: didn't work 
  • Opening an existing RGB document or new RGB document, first thing as soon as I start Photoshop: nothing
  • disabling OpenGL drawing in Photoshop's preferences: nothing
Has Adobe released any other fix/workaround other than the above, none of which work for me??

It's unbelievably frustrating to work without Transform Controls/Bounding boxes, the most I could do was to get Layers Edges to show (View > Show > Layer Edges), but that still doesn't help when trying to transform layers. 

I am going back to CC 2018!
Photo of paul kettlewell

paul kettlewell

  • 14 Posts
  • 22 Reply Likes
This reply was created from a merged topic originally titled Transform controls have completely disappeared.

In a CMYK document - and the transform controls have completely disappeared 

Only solution I found was after reading it somewhere else to change mode to RGB and then back again to CMYK

This conversation is no longer open for comments or replies.