Photoshop: Plastic filter creates black artifacts (macOS 10.14 Mojave)

  • 1
  • Problem
  • Updated 2 weeks ago
  • (Edited)
There are black artifacts in the photo after using the "Plastic" filter in macOS Mojave - AMD Radeon R9 M370X 2048 MB graphics card.
Attention!
These artifacts DO not OCCUR in mac OS High Sierra - AMD Radeon R9 M 370 x 2048 MB video card!  So the graphics card is in order! Fix software conflict, please!
Photo of Виктория Винс

Виктория Винс

  • 1 Post
  • 0 Reply Likes

Posted 3 months ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14991 Posts
  • 2086 Reply Likes
Does disabling "Use Graphics Processor" under Preferences > Performance... and restarting Photoshop make the issue go away?
Photo of Sergey Soloduho

Sergey Soloduho

  • 2 Posts
  • 0 Reply Likes
Yes. Disables.
But this is not an option?
Fix software conflict, please!
(Edited)
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14991 Posts
  • 2086 Reply Likes
See here for details and workarounds: Black artifacts on image after using the Liquify filter It's a driver issue. We're working with Apple to address this issue.
Photo of Sergey Soloduho

Sergey Soloduho

  • 2 Posts
  • 0 Reply Likes
оk! Thanks you. 
Photo of Eduardo Bertoli da Cunha

Eduardo Bertoli da Cunha

  • 2 Posts
  • 0 Reply Likes
Is there any other solution? disabling "use graphics processor" it takes AGES to work
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14991 Posts
  • 2086 Reply Likes
Roll back to macOS 10.14.1, or install CC 2018 until the graphics driver is fixed/updated.