Mixing Visual C ++ runtime versions

  • 1
  • Question
  • Updated 3 years ago
  • (Edited)
On Windows 10 and probably other versions, Lightroom and Photoshop need Visual C in prehistoric versions : 2010, 2012, .. and when you install them with CC you end up with 8 versions from 2008 to 2013 in x86 and x64 ! Why such a mess ?
Photo of Markos Malliarakis

Markos Malliarakis

  • 2 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 818 Reply Likes
Because older plugins and some third party libraries are built with older versions of VisualStudio and need those older runtime libraries.
It isn't a mess - it is the design imposed by Microsoft if you use their development tools.
Photo of Markos Malliarakis

Markos Malliarakis

  • 2 Posts
  • 0 Reply Likes
Thank you, as an Insider you get more interested under the hood and sent the same reflection to Microsoft. Will they move with "Windows as a Service" ?
Bravo for Lightroom that stays a remarkable tool (the others also) !