Lightroom Classic: Migrating catalog, but message is saying the catalog is damaged

  • 1
  • Problem
  • Updated 4 months ago
  • (Edited)
I saved a catalog in lightroom CC 2015.6.1 release, which will not open on my new macbook pro running Adobe lightroom classic cc 7.2 release.

When I attempt to open this catalog, it tells me that the catalog needs to be upgraded, then the following message appears: "lightroom couldn't update the format of its catalog file because the file appears to be damaged".

Other catalogs created in the same version have migrated and upgraded to the new version without issue.  The damaged catalog still opens on the old mac in CC 2015.6.1 without issue.

Has anyone had this problem, and do you have any suggested fix? 
Photo of Barend Becker

Barend Becker

  • 1 Post
  • 0 Reply Likes

Posted 4 months ago

  • 1
Photo of Rikk Flohr

Rikk Flohr, Champion

  • 1373 Posts
  • 334 Reply Likes
Have you attempted to repair the catalog using File>Optimize Catalog...?
Do you have recent backups?
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4128 Posts
  • 1472 Reply Likes
And have you tried copying it over again? It could have become corrupted while transferring.