Lightroom: Metadata Export is not working ("Read-only file") for substituted folders on Windows

  • 1
  • Problem
  • Updated 10 months ago
  • (Edited)
On my Windows machine, the folders containing the raw photos are on a substituted drive ("P:", the actual folder is e:\photos_lightroom, see https://technet.microsoft.com/de-de/library/bb491006.aspx)

On all photos that are on this substituted drive, I get the error "Photos have read-only access" when trying to export metadata to the file (see attached screenshot).
The files do not have "Read-only" access set in the windows explorer.


The affected Lightroom Versions are (at minimum) Lr 4 (all versions) and Lr 6 through 6.12.

Would there be an easy fix for this? This problem is really annoying me.

Thank you very much in advance for your reply!

Kind Regards,
Christian
Photo of Christian Denk

Christian Denk

  • 4 Posts
  • 0 Reply Likes

Posted 10 months ago

  • 1
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 1047 Posts
  • 401 Reply Likes
Maybe Lightroom has a problem with this kind of 'virtual disk'. Why do you use this in the first place? Why don't you simply 'relink' the folders in Lightroom to the real disk?
Photo of Christian Denk

Christian Denk

  • 4 Posts
  • 0 Reply Likes
My setup is dependent on this virtual disk - as I am using two PCs in different locations to edit the same catalog.
One PC uses the photos stored on a network drive (that is mapped to e.g. "P:"), the other PC has the photos physically on "e:\photos_lightroom" - and thus needs to map this to "P:").

In my view, this is a bug - substituted drives is nothing unsusual and a standard windows feature - Lightroom should be able to handle those appropriately.
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 1047 Posts
  • 401 Reply Likes
I'm not a PC user but I know that you can give a disk a fixed drive letter in Windows, so why don't you simply make that P: for your non-network PC as well? https://www.lifewire.com/how-to-change-a-drive-letter-2626069 Maybe this is indeed a bug, but I assume you want a working solution...
Photo of Christian Denk

Christian Denk

  • 4 Posts
  • 0 Reply Likes
thank you - but this is not an option, as I my folder layout is also different between the two setups, so just assigning a different drive letter won't help.
Photo of John R. Ellis

John R. Ellis, Champion

  • 3372 Posts
  • 844 Reply Likes
I agree that LR should be able to handle "subst" drives. Here's a workaround: On the computer having the photos on a locally attached drive, map a network drive to the appropriate folder and assign it P: .
Photo of Christian Denk

Christian Denk

  • 4 Posts
  • 0 Reply Likes
Thanks, I'll give it a try!

Best,
Christtian