Photoshop: Measure Tool reports false distances when snapping to guides

  • 1
  • Problem
  • Updated 6 years ago
  • (Edited)
When you drag the Measure Tool between two guides, it snaps to the second guide but never displays the correct distance in the toolbar.

I've done a nice wee screencast for you to demonstrate:

http://test.stephband.info/screencast...

Cheers,
@stephband
Photo of Stephen Band

Stephen Band

  • 2 Posts
  • 0 Reply Likes
  • *sigh*

Posted 6 years ago

  • 1
Photo of Pete Green

Pete Green, Customer Advocate

  • 699 Posts
  • 126 Reply Likes
That's a weird one -- I've been able to create rulers using pixels as the measurement value, added guides at 0 and 140px, and used the ruler tool to measure the distance and mine came up with 140px.

You say this problem has been around for some time?
Are you selecting anything in particular that might be causing the mis-measurement?

Have you tried resetting your preferences by chance? http://helpx.adobe.com/photoshop/usin...
Photo of Stephen Band

Stephen Band

  • 2 Posts
  • 0 Reply Likes
This is a clean install on a new machine. I did not import my preferences from my previous Mac. I have seen this problem on 4 or 5 machines over the last few years.

I am doing nothing special with the graphics. Two guides in a blank document will produce this effect, with nothing selected.

My workaround is to zoom out to 100% and use OS X's Screen Capture key command (SHIFT-APPLE-4), which displays pixel values while dragging, to measure stuff.
Photo of Dan Smith

Dan Smith

  • 225 Posts
  • 17 Reply Likes
Are the values different in the info panel?
I'm on a mac and if i draw a fixed selection of 140 px X 140 px and put guides at the sides of the selection, draw out the ruler tool, the measurement in both the info panel and toolbar are the same 140 px