Elements 14:Massive memory leak when processing faces in Organizer

  • 1
  • Problem
  • Updated 2 years ago
  • (Edited)
Hello,

OS: Windows 7 64-bit, fully patched

I have observed huge memory leaks in Organizer 14 when processing faces. My scenarios:

1. Organizer 13 database with 35k photos and ~45 named faces. After upgrade to v14, Organizer started processing faces anew (preserving face name assignments from v13). Now, for each ~6-8k photos it consumed ~6GB of memory which was not returned to system, resulting in Low memory message and OS shutting down the Organizer. I have confirmed, that it was Organizer process that consumed memory. I have completed finally all processing in batches, and memory leaks were persistent among computer reboots/restarts and Organizer restarts - always at the same rate.

2. After completing above, I ended up with 12k (right - 12 thousand - I have lots of faces) face stacks. I started processing them, resolving unconfirmed faces for named faces and face stacks. After an hour or so of work, I ended up again with Low Memory Message for Organizer. This has happened just once for now, but I guess only because this was my first batch of work after the re-scanning.

Have you observed something like this? I have Task Manager screenshots for the first scenario, and I think I can easily make some for the second.

TIA & Regards
Photo of Lukasz Jakubowski

Lukasz Jakubowski

  • 28 Posts
  • 1 Reply Like

Posted 2 years ago

  • 1
Photo of Lukasz Jakubowski

Lukasz Jakubowski

  • 28 Posts
  • 1 Reply Like
And here is how it looks with Task Manager refresh set to Slow