Photoshop CC 2017: Magic Wand tool selects entire document

  • 1
  • Problem
  • Updated 2 years ago
  • Solved
  • (Edited)
When using the magic wand tool, as soon as I click to start my selection, everything in the image is selected and the icon changes to an arrow with a dotted box next to it. I've reset the tool multiple times and re-started but cannot resolve this ?
Photo of Derek Warren

Derek Warren

  • 7 Posts
  • 2 Reply Likes
  • frustrated

Posted 3 years ago

  • 1
Photo of Michel DELFELD

Michel DELFELD

  • 251 Posts
  • 36 Reply Likes
it depends on the tool setup. The tool sensibility is modified with the setup button "tolerance" in the upper  left side of PS screen
Photo of Derek Warren

Derek Warren

  • 7 Posts
  • 2 Reply Likes
Thanks for your reply, I have tried tolerance all the way up from 0 to 255 but the problem still persists.
Photo of Michel DELFELD

Michel DELFELD

  • 251 Posts
  • 36 Reply Likes
Are you having this effect on different pictures 
Photo of Derek Warren

Derek Warren

  • 7 Posts
  • 2 Reply Likes
Yes, doesn't matter which image I use, jpg, psd, raw ?
Photo of Michel DELFELD

Michel DELFELD

  • 251 Posts
  • 36 Reply Likes
what is the OS your are using?
Photo of Derek Warren

Derek Warren

  • 7 Posts
  • 2 Reply Likes
Windows 10
Photo of Michel DELFELD

Michel DELFELD

  • 251 Posts
  • 36 Reply Likes
Sorry I think the problem you have may be related to the OS you are using. I am not a specialist of Windows
May I suggest you to make a cold start of your computer?
Photo of Derek Warren

Derek Warren

  • 7 Posts
  • 2 Reply Likes
Thanks, i'll give it a try and let you know.
Photo of Derek Warren

Derek Warren

  • 7 Posts
  • 2 Reply Likes
No luck i'm afraid.

When I come to think of it, this is the first time i've tried this operation since upgrading from Photoshop 2015 so I might try going back to the previous version if that's possible.
Photo of Michel DELFELD

Michel DELFELD

  • 251 Posts
  • 36 Reply Likes
May be 
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15586 Posts
  • 2344 Reply Likes
Official Response
Do you have "Sample All Layers" unchecked? And/or do you have an empty layer, or solid color layer (like a white background) selected? (This will create a selection of the entire document) Make sure your layer has image content on it or make sure "Sample All Layers" is checked.
Photo of Derek Warren

Derek Warren

  • 7 Posts
  • 2 Reply Likes
Sample all layers was unchecked, thanks for your help, i'm a new user so finding it a bit daunting at the moment.  Thanks again
Photo of Toilet Feast

Toilet Feast

  • 1 Post
  • 1 Reply Like
I found a weird little icon in the lower left-hand corner of the screen that toggles between a black background with a white, dotted circle, and a white background with a black circle when you click on it.  Click on it.  Worked for me!  Hope that helps you, and the many people like us.