Mac OS X Quicklook no longer shows PSDs

  • 2
  • Problem
  • Updated 6 years ago
  • Solved
When I use Quicklook on Mac OS X 10.6.7 it has stopped showing the previews of my PSD files.

This has gone on for about 2 weeks now.

Attempted fixes: Disable Maximize Compatibility, restart app, enable Maximize Compatibility.

Of note, when I set Max. Comp. to 'Ask', even after restarting, it never asked.
Photo of Julian Kussman

Julian Kussman

  • 18 Posts
  • 0 Reply Likes
  • frustrated

Posted 7 years ago

  • 2
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13996 Posts
  • 1700 Reply Likes
Hmm. I just tried this with 10.6.7 and it's working for me.
Photo of Julian Kussman

Julian Kussman

  • 18 Posts
  • 0 Reply Likes
Yeah, it used to work, now it doesn't. Obviously it works for you guys or you'd be reporting it too. FYI I don't like these "works for me" responses I keep getting because I do have the problems I post.

Can you find out what could cause such functionality to stop working?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13996 Posts
  • 1700 Reply Likes
When we say it's working for me, we're giving you a clue that the problem specific to your system. Sorry if it comes off as flippant. Basically, we'd need more info on what's different about your system.

I can offer a guess given Quicklook relies on QuickTime. Do the PSDs display correctly if opened in QuickTime or Preview? Do you have any third party codecs installed for QuickTime?

Quicklook and QuickTime are Apple's technology - so, at least with this issue, you may want to hit Apple's support forum.
Photo of Julian Kussman

Julian Kussman

  • 18 Posts
  • 0 Reply Likes
The PSDs no longer display in Preview and I do not have any Quicktime codecs installed.

The preview/quicklook images stopped working at a time when no new changes had been made to the system.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13996 Posts
  • 1698 Reply Likes
Can you post one of the PSD that you're having trouble with?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13996 Posts
  • 1698 Reply Likes
If you hold down Shift + Cmd + Opt when you open one of the affected PSD i, does it give you the option to "Read Composite Data"?
Photo of Julian Kussman

Julian Kussman

  • 18 Posts
  • 0 Reply Likes
I did a test with a simple 2 layer PSD. It showed preview correctly. Now it seems the only files that do not show correctly are in one project I am working on (all files were made of dupes of 1 file).

Doing the trick you stated I do get the "Read Comp..."

Is there any way to 'fix' a few PSDs if they get broken in this way?

Their file size is too big for me to upload.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 780 Reply Likes
No, the PSD files are fine. What you're describing is a bug in Apple's PSD parsing code (just add it to the list of other bugs we've filed with them...).
Photo of Julian Kussman

Julian Kussman

  • 18 Posts
  • 0 Reply Likes
Since quicklook and quicktime accept plugins to affect what files get viewed and how, can Adobe make a plugin that circumvents this issue? Obviously not quickly, but for the future.
Photo of Andy Wilkinson

Andy Wilkinson

  • 1 Post
  • 2 Reply Likes
I had this precise problem and found a solution here:

http://forums.adobe.com/message/3101145

In my case, I needed to turn on Maximise Compatibility in Preferences > File Handling.

That is all, no idea why that is the case.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 780 Reply Likes
Maximise Compatibility puts a flattened image into the file, along with the layers. The MacOS code is probably looking only at the flattened image.