Mac OS10.12.4 and CC 2017 failure

  • 1
  • Problem
  • Updated 1 year ago
I updated to OS 10.12.4 after searching for potential issues and finding none. Now Photoshop does not open.

Yes, I uninstalled, ran cleaner, restarted, and reinstalled. No difference.

Without providing the entire log, here is a part that seems to indicate where the error is occurring:

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_INSTRUCTION (SIGILL)
Exception Codes:       0x0000000000000001, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Illegal instruction: 4
Termination Reason:    Namespace SIGNAL, Code 0x4
Terminating Process:   exc handler [0]

Application Specific Information:
dyld: in dlopen()
BUG IN LIBTRACE: MH not found

Any thoughts?

Wade
Photo of Wade

Wade

  • 4 Posts
  • 0 Reply Likes
  • anxious

Posted 1 year ago

  • 1
Photo of SG...

SG..., Employee

  • 136 Posts
  • 25 Reply Likes
Hi,

Can you check to see if this is a 3rd party plug-in issue?  Hold down the Shift key at launch, and click on Yes to skip loading 3rd party plug-ins. More info in the link below.

https://helpx.adobe.com/photoshop/kb/plug-ins-photoshop-troubleshooting.html#Pluginstroubleshootingsteps

thx, 
steve
Photo of Wade

Wade

  • 4 Posts
  • 0 Reply Likes
Still crashed first time, started second time. I had removed all plugins and add ons, or I thought I had.

Now the fun begins.

Thanks for the help, I had forgotten about specifically starting Photoshop like that.
Photo of SG...

SG..., Employee

  • 136 Posts
  • 25 Reply Likes
Good to hear you are past the crash on launch! Do you have a screen capture of the plug-ins you can share?

thx,
steve
Photo of Wade

Wade

  • 4 Posts
  • 0 Reply Likes
Found it, It was one of the Perfect Effects V8 Plugins. Don't know which one, I deleted them all as I don't use them. Some cleanup was good to do.

They were nested in the Photoshop Only folder.

Thanks for the reminder!
Photo of SG...

SG..., Employee

  • 136 Posts
  • 25 Reply Likes
Hi Wade,

If you want to use the On1 plugins in the future, take note of this announcement for previous versions: https://on1help.zendesk.com/hc/en-us/articles/115004702248

cheers!
steve
Photo of bikracer

bikracer

  • 1 Post
  • 0 Reply Likes
This thread is so helpful! Thank you so much for being so specific and continuing on through the result.