Mac High Sierra problems with CS5

  • 1
  • Problem
  • Updated 6 months ago
I have PS CS5 extended 12.1x64 and since the new Mac High Sierra (10.13.1) update I am experiencing problems with jerky movements and not responding correctly to instruction.  I don't really want to update my PS as I am so used to it...but are the CS5 and High Sierra not compatible at all?  
Photo of Liz Ascroft

Liz Ascroft

  • 1 Post
  • 0 Reply Likes

Posted 6 months ago

  • 1
Photo of Warren Heaton

Warren Heaton

  • 52 Posts
  • 16 Reply Likes
macOS High Sierra marks some significant changes under the hood for the OS.  Any components of PS CS5 that relied on the OS to function may not work as expected or at all.

For comparison, the version of Final Cut Pro that was new when CS5 was new will not even open under High Sierra.
Photo of Michel DELFELD

Michel DELFELD

  • 241 Posts
  • 33 Reply Likes
It may be that CS5 is not usable with Sierra or High Sierra
FCPx V10.3 is compatible with High Sierra. earlier version are not completely compatible as for instance the video tools (luminance and vectorscope