LR 5.3 screwed up resize on export

  • 4
  • Problem
  • Updated 4 years ago
Since upgrading to LR5 latest release 5.3, specifying a short side limit to an export (in my case, 640) does nothing; the file is exported in the original size.

A workaround is to specify the desired long side so as to get a short side of 640 pixels.

EXCEPT . . . for some files, nothing works. I've not found anything special about those files, and I've tried both processed and as imported versions

In case it's not clear, it does not matter what numbers you enter in there. It fails consistently.

Just so there is no assumption regarding me being an idiot unable to work an export dialog (I might be for other stuff, but not this), I can go to LR4, LR 5, and 5.2, and the same files export without any problems with regard to resizing.

The files are all NEF files imported directly from camera, but I tested with other files (JPG, TIFF, PSD), and same problem occurs.

As for settings, nothing seems to affect the behavior . . . if I choose short edge resize, regardless what other stuff I ask for, it does not work. However, for the record, I choose a location, I choose 72dpi, I choose do not enlarge (I tried without it), JPG at 80%, sRGB, normal sharpening for screen, and a watermark (I tried without the watermark).

It's not comforting to find no mention or admission of a bug anywhere on these forums.

I am a big fan of LR, but putting out releases to "fix" minor bugs and add compatibility, and screwing up a basic function that has worked for years is no way to inspire confidence on future updates.

Meantime, I'm reverting to earlier version.

ejd
Photo of Emilio J. D'Alise

Emilio J. D'Alise

  • 6 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 4
Photo of Emilio J. D'Alise

Emilio J. D'Alise

  • 6 Posts
  • 0 Reply Likes
I misspoke . . . the problem ONLY occurs when the "do not enlarge" box is checked.

I guess I am an idiot after all.

Regardless; bug.
Photo of Mark Anderson

Mark Anderson

  • 1 Post
  • 0 Reply Likes
I have the same problem, and like you found that unsetting "do not enlarge" prevents it... fine as long as I'm not exporting images smaller than I am resizing to.

When resizing to long edge or within dimensions, the problem only seems to occur if the short edge of the original is smaller than the dimension set for resize. For example, if I set resize long edge to 2000px:-

* an image 5000x1999 is not resized
* an image 5000x2001 is resized

Frustrating that this bug appeared in 5.3, and the time it took me to figure out I what was going on.

Hopefully Adobe will fix this soon.
Photo of Juhani Pykäläinen

Juhani Pykäläinen

  • 3 Posts
  • 0 Reply Likes
I also have the resizing problems with TIFF files in Lightroom. If I open a NEF file in CS6 as external editor and then resize the TIFF to 1280x864, the export resizing in LR with 1024 (long edge) fails.

1280x864 TIFF -> fails to resize jpg output to 1024 every time
1280x864 TIFF -> output to 480 successful (maybe due to significant difference in size)
1280x1280 -> output to 1024x1024 successful

It seems that the problem occurs also with other image sizes, when original aspect ratio used and resizing only moderate.

I have to uncheck the "do not enlarge" box and wait for the correction.