LR 4.2 RC does not overwrite 4.1

  • 1
  • Problem
  • Updated 6 years ago
  • (Edited)
LR 4.2 RC does not overwrite 4.1 (tried 3 times with restarts even) on my MacPro (current Mt Lion). Nor does RAW 7.2 show up anywhere after the installation. Is there a setting I need to change?
Photo of Akos Szilvasi

Akos Szilvasi

  • 3 Posts
  • 0 Reply Likes
  • puzzled

Posted 6 years ago

  • 1
Photo of jdv

jdv, Champion

  • 728 Posts
  • 55 Reply Likes
Do you mean, does the 4.2RC install replace 4.1? This is correct, it does not (at least on a Mac). If you think about it, this is a good thing. It will be installed next to any other releases of Lightroom you have installed. Once it is no longer an RC will you see the point releases make changes to installed apps.

Also, ACR is part of the Lightroom app, not a separate install. So you will not see 7.2 anywhere on your system. You can install it separately if you like.

See: http://labs.adobe.com/technologies/li...
Photo of Akos Szilvasi

Akos Szilvasi

  • 3 Posts
  • 0 Reply Likes
Hi, This is Akos, again. LR 4.2 RC installed (3 times) without any problem..or better said the installer went through the normal process. Even gave me an info box to say that it'll update the current version. Then no change. 4.1 is 4.1 and the RAW is 7.1. I could not find a separate LR (besides my old version 3) on the computer. Not even with the "find" function. Quite a mystery.
Photo of jdv

jdv, Champion

  • 728 Posts
  • 55 Reply Likes
My mistake, you /can/ installed it alongside your previous releases (you can choose a new location when you run the install.) By default it overwrites the existing 4.x release.

If it is not updating the installed version of 4.x, then you might have a permissions problem. Are you installing it to the default location? You can also try running the installer from a test account you create for testing. Or just install it to a parallel directory structure.
Photo of Akos Szilvasi

Akos Szilvasi

  • 3 Posts
  • 0 Reply Likes
Thanks, John, for the suggestion. I'll look into it at home tonight. Yes, I installed to the default location and I am the only user of this computer.

Interestingly, when I did the same (installation of 4.2 RC) on a MacBook Pro laptop it went through all right and changed 4.1 to 4.2 RC. I have not had a chance to test it yet. I am especially interested in the Sony RX100 RAW support.