LR 4.1: Unknown file I/O error on Save Metadata with active filter in Library module

  • 1
  • Problem
  • Updated 6 years ago
LR 4.1 / W7x64

[b]To reproduce the issue[/b]:
• in the Library module select a bunch of jpeg or raw or dng shots via a Metadata filter
> thumbnails displayed according to the filter
• edit/fill any metadata for some photos
• add to the filters a 'Metadata Status' column
• select 'Has been changed' in this column
> thumbnails list refined according to the new filter (i.e., only shots with unsaved metadata)
• select all the thumbnails, perform 'Save Metadata' (hit Ctrl+S)
> metadata edits are saved back to the files, thumbnails progressively disappear from the library view in agreement with their change of metadata status

at the end of the operation, a warning box is displayed stating an "Unknown file I/O error" for a few files - usually the first few ones. These photos later show as Metadata Status: 'Unknown' in the filter columns, their thumbnails display an exclamation mark stating 'Sidecar file has conflict' (which is actually wrong, there is no such thing as a sidecar file if saving metadata to jpeg files).

Of course saving metadata again (or clicking the exclam. mark) solves the issue in a snap. No big deal, but at best misleading/cryptic error msg, and at worst some unsaved metadata that needs to be saved again.

[b]Wild guess[/b]:
concurrent file access/overburden between [i]Save[/i] operation and [i]Thumbnails list display/filtering[/i] operation results in some internal conflict.
I guess the filtered thumbnail list is "too responsive" somehow, thus getting in the way of successfully saving metadata and/or recording the change in metadata status.
Photo of Chris Packrat

Chris Packrat

  • 30 Posts
  • 2 Reply Likes
  • confused

Posted 6 years ago

  • 1
Photo of LRuserXY


  • 426 Posts
  • 41 Reply Likes
Just FYI (does not help with your actual problem): I already reported the "sub-problem" of the wrong tooltip. Not only the tooltip text is misleading - it is also the wrong tooltip altogether, see here:

The tooltips "error writing metadata" and "Sidecar file has conflict" are still mixed up in 4.1.
Photo of Chris Packrat

Chris Packrat

  • 30 Posts
  • 2 Reply Likes
Your problem is not a bug, it's a feature. Or an idea, why not. Or, oh wait, no, that's a problem indeed.