Lightroom: 3.5RC DateTimeDigitized Loss

  • 5
  • Problem
  • Updated 2 years ago
  • Solved
  • (Edited)
Considering scanned images, with existing, but different, values for DateTimeOriginal and DateTimeDigitized...

A. In LR version 3.3 (& possible prior versions): XMP:CreateDate appears to have been mapped to an existing value for DateTimeOriginal. I believe it should have been mapped to the existing DateTimeDigitized, as noted by the MWG. This issue may be one cause for the incorrect digitized dates noted by users of 3.4 & 3.5RC.

B. In LR version 3.5RC: Recommend retaining the XMP:DateTimeDigitized tag. Currently, this tag is deleted by 3.5RC (and perhaps 3.4), which prevents corrective action due to the problem noted above for LR3.3 (i.e. autosave metadata or ctrl-s deletes the date digitized information from original file). Per the MWG, 3.5RC is using the CreateDate as the digitized date, but that value is no longer correct as created by LR3.3.

Due to the possible loss of the DateTimeDigitized data by 3.5RC, I'll need to revert back to LR3.3. Though the CreateDate appears to be incorrect with LR3.3, at least the original digitized data is retained, and I can evaluate my options from there.

Below is an example flow of data from one of my scanned images...

1. Original scans are tagged as follows (with Exiftool):
[EXIF] Date/Time Original : 1985:04:17 12:00:00
[XMP] Date/Time Digitized : 2011:06:27 20:43:15-05:00

2. Scans were imported into LR3.3. Saved metadata now shows the first hints of a problem, as CreateDate has been mapped to DateTimeOriginal (DTO) by LR3.3.
[EXIF] Date/Time Original : 1985:04:17 12:00:00
[XMP] Date/Time Digitized : 2011:06:27 20:43:15-05:00
[XMP] Modify Date : 1985:04:17 12:00:00-05:00
[XMP] Create Date : 1985:04:17 12:00:00-05:00

3. Scans were then imported into 3.5RC, and the digitized date now incorrectly reflects the DTO date in the metadata panel (symptoms reported in other threads). Saving the metadata to the file yields the following (ctrl-s). **The initial digitized date has been completely lost.**
[EXIF] Modify Date : 1985:04:17 12:00:00
[EXIF] Date/Time Original : 1985:04:17 12:00:00
[XMP] Create Date : 1985:04:17 12:00:00-05:00
[XMP] Metadata Date : 2011:08:30 11:10:26-05:00
[IPTC] Date Created : 1985:04:17
[IPTC] Time Created : 12:00:00-05:00

4. Finally, if we export the image from 3.5RC, we have the following in the new image. We note the creation of the new IPTC digitized tag, which, of course, no longer reflects the original digitized tag.
[EXIF] Modify Date : 2011:08:30 11:28:20
[EXIF] Date/Time Original : 1985:04:17 12:00:00
[EXIF] Create Date : 1985:04:17 12:00:00
[XMP] Metadata Date : 2011:08:30 11:28:20-05:00
[IPTC] Date Created : 1985:04:17
[IPTC] Time Created : 12:00:00-05:00
[IPTC] Digital Creation Date : 1985:04:17
[IPTC] Digital Creation Time : 12:00:00-05:00

(Win 7, x64)
Photo of Gary Peterson

Gary Peterson

  • 18 Posts
  • 1 Reply Like

Posted 7 years ago

  • 5
Photo of Benjamin Warde

Benjamin Warde, Employee

  • 483 Posts
  • 74 Reply Likes
Official Response
The final release of Lightroom 3.5 is now available for download (go to Help>Check for Updates within Lightroom, if it doesn't prompt you automatically). In 3.5, this issue is fixed-ish. Editing the capture date/time will no longer change the date/time digitized in the Lightroom UI. When actually writing the info out to the metadata in the file, we're still not quite writing to all the correct (according to the MWG spec) metadata fields. That fix is still pending.

Thanks,
Ben
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14549 Posts
  • 1892 Reply Likes
Official Response
According to the internal bug system, this was fixed in Lightroom 3.6 and later.