Lightroom: LR 3.5 introduces Spot Removal drawing issue

  • 1
  • Problem
  • Updated 7 years ago
  • (Edited)
Since upgrading to Lightroom 3.5, clicking with a large Spot Removal tool in a dark corner of an image causes a drawing bug along the edge of the photo covered by the tool. This does not happen when clicking with the tool completely over the image (or if it does, the error is hidden by the white edges of the spot removal indicator) and it doesn't seem to happen if the bits under the image are light colored. Zooming in fixes the drawing bug. It seems to be random noise, 1 px wide, along the image edge. The bug also doesn't persist in exported JPEGs. It seems purely to be a drawing bug in the UI.

Example:

Before spot removal

After spot removal
Photo of Warren Young

Warren Young

  • 32 Posts
  • 1 Reply Like

Posted 7 years ago

  • 1
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4128 Posts
  • 1472 Reply Likes
Hi Warren, can you please confirm OS and system specs, including graphics card? And have you tried updating the graphics driver direct from the manufacturer?
Photo of Warren Young

Warren Young

  • 32 Posts
  • 1 Reply Like
This is on an early 2008 Mac Pro running OS X 10.6.8 64-bit, upgraded to have an NVIDIA GeForce GTX 285.

I found this problem with the 256.00 NVIDIA drivers. I upgraded to the latest-as-of-today drivers (256.02.mumble) and the problem persists.
Photo of Warren Young

Warren Young

  • 32 Posts
  • 1 Reply Like
I tried to replicate it on my Lion laptop (early 2011 MacBook Pro with Intel graphics) and couldn't. So, it could be Snow Leopard or GPU specific.