LR 3.4.1: browsing photos in crop mode: better initial preview

  • 4
  • Idea
  • Updated 6 years ago
In the development module, in crop mode, when advancing to the next photo (e.g. using Ctrl-Right), LR initially displays a "preliminary" version of the photo (from the preview cache?) and displays "Loading...".

Problem: This seems to happen in two stages, and in the first stage, most of the time the already-cropped version of the photo is displayed over the whole image area, making it appear larger than it really is (and sometimes distorted, depending on the crop rectangle or angle). In the second stage, it "snaps" back into its correct place inside the crop rectangle.

When browsing a number of photos to review the crop settings made, this can be a little bit annoying (even if the first stage is very short), especially on a not-so-fast computer (i use LR on Windows XP 32 Bit, Intel Core2 6700). However, it's not so bad that I would consider it a real bug or problem (hence I posted this as an idea).

I added two screenshots for illustration: #1 show the first stage with the wrong display, and #2 shows the final display where the photo is correctly shown in the crop rectangle (exaggerated crop on purpose).

So the idea is: When initially loading a photo in crop mode, the preview (?) image should be already scaled so it fits correctly into the crop rectangle.

Photo of LRuserXY


  • 426 Posts
  • 41 Reply Likes

Posted 7 years ago

  • 4
Photo of LRuserXY


  • 426 Posts
  • 41 Reply Likes
This still annoys me at times. Sometimes I browse through a set of photos in crop mode (using Ctrl-Left/Right to navigate) to check the crop for each photo (so contrary to loupe, I am able to see also what areas were cropped away).

It does not matter whether standard or 1:1 previews were rendered or not: When advanding to the next photo in crop mode, the high quality preview is practically instantenously loaded, but not correctly scaled and transformed into the crop rectangle, but strangely distorted like in the first screenshot of my original post. Only when ACR kicks in and renders the photo by itself, that distorted state is corrected. There seems to be some kind of caching when browsing the same three or four photos, but in general it does not seem to depend on whether the photo is already in the ACR cache or not.

Now I wonder: Am I the only one that does this from time to time, or are there others, who are annoyed by this behaviour, too? If there are others, please vote :-)

Now using LR 4.1 final 64Bit on Windows 7.
Photo of TK


  • 531 Posts
  • 108 Reply Likes
This has been annoying me as well, but other things like a missing temporary eraser keyboard flow control or performance issues have been higher up my personal priority list.

Not to say that this issue is not worth fixing, but I guess it may not happen anytime soon.
Photo of Allan Olesen

Allan Olesen

  • 64 Posts
  • 6 Reply Likes
It annoys me too, and I think it is part of a larger UI problem:

When moving to a new picture, UI updates are trickling onto the screen at semi-random intervals, and you never quite know when the screen is fully updated.

Does the Pick flag I see right now belong to this photo or the previous photo?

Do I see the correct crop?

There is no visual indication that all UI elements has finished updating. So I tend to just sit there and wait a few seconds more than necessary, so I am certain that everything is updated before I go on editing the photo.

At least the sliders are grayed out until they are updated. Something similar would be really nice with other UI elements.