Lightroom Classic 9: Will not open upgraded catalog

  • 2
  • Problem
  • Updated 8 months ago
  • (Edited)
I downloaded the LR9 update from LR8.4.1, a new catalog was generated as expected, but LR 9 will not open it. When I try, I get the message that the new upgraded catalog-2 "cannot be opened because it is too new to be used by this version of Lightroom". I have had the catalog checked out by the kind folks at LR Queen, and it opens fine for them. I've tried multiple de- and re-installations of LR9 - same problem every time. Had to revert to the original catalog and LR8.4.1
Photo of John Woodman

John Woodman

  • 21 Posts
  • 1 Reply Like

Posted 8 months ago

  • 2
Photo of john beardsworth

john beardsworth

  • 1359 Posts
  • 375 Reply Likes
When you try to open it, are you double clicking catalog-2 or an old desktop shortcut which points to a previous Lightroom - hence the message.

Try opening LR9 from Adobe's Creative Cloud App, or by double clicking the program, and then tell it to open catalog-2.
Photo of John Woodman

John Woodman

  • 21 Posts
  • 1 Reply Like
Double-clicking the updated catalog. If I try to run it from the CC App immediately after downloading, I get a crash immediately after the first LR screen. The crash reports have been submitted to Adobe, but no feedback.
Photo of john beardsworth

john beardsworth

  • 1359 Posts
  • 375 Reply Likes
Any error message? What operating system?

Avoid double clicking the upgraded -2 catalogue, for now. Instead, reboot the computer, clear any *. lock or *.wal folders from the folder containing the -2 catalogue, then go into the CC App and try to start LR9.
Photo of John Woodman

John Woodman

  • 21 Posts
  • 1 Reply Like
Appreciate your help. Did all those things when it first happened several days ago. When the newly-downloaded LR9 crashes from the CC App, there is no error message - just the start-up screen for a few seconds and then the crash report window. This is on Windows 10. Reluctant to download LR9 again, because that erases LR8.4.1 and I need a working catalog.
Photo of john beardsworth

john beardsworth

  • 1359 Posts
  • 375 Reply Likes
What about updating your graphics card driver?

You might want to try removing your preference files and restarting LR9 clean, but I doubt it would matter here.
Photo of John Woodman

John Woodman

  • 21 Posts
  • 1 Reply Like
Updated the driver recently. It is the current nvidia driver, from October 2018. This is causing minor problems with ON1, but never with LR so far.
Photo of Chinoy Gupta

Chinoy Gupta, Employee

  • 83 Posts
  • 38 Reply Likes
Hi John,

An issue related to Catalog Upgrade was fixed in LrClassic 9.1 which released this week. Can you update to that version and try catalog upgrade again.

Thanks,
Chinoy
Photo of Ruby Ye

Ruby Ye

  • 1 Post
  • 0 Reply Likes
This reply was created from a merged topic originally titled When update LR classic, can not update catalog.

After I updated LR classic from 8.4 to 9.1, I get an message that: "Lightroom encountered problem when trying to update the format of the catalog file and can not use this catalog with this version of lightroom