Lightroom Classic 9: Can't find photos on card reader- macOS 10.15 Catalina

  • 1
  • Problem
  • Updated 3 months ago
  • (Edited)
Merged

This conversation has been merged. Please reference the main conversation: Lightroom Classic: Fails to import photos and stalls out on macOS 10.15 Catalina

My wife updated to LR 9 on her MacBook Pro running Catalina.  When she tried to update from her card reader, LR could not find any photos.  I used Finder to import the files to her external hard drive, but LR could not find the photos either.  The screen just said "No Photos Found."  I spend almost two hours chatting with Adobe tech (not customer) support who took control of my wife's computer and tried to get LR 9 to work but couldn't.  The source list also showed her Macintosh HD (internal drive) listed three times.  During his attempts, another three Macintosh HD entries appeared but these had weird suffixes.  Finally he said this was a known problem and Adobe hoped to have a fix in a few days.  He rolled her LR back to version 8.4.1 and everything works again.
Photo of Richard Hix

Richard Hix

  • 31 Posts
  • 5 Reply Likes
  • sad, confused

Posted 3 months ago

  • 1
Photo of Margaret Kelley

Margaret Kelley

  • 4 Posts
  • 0 Reply Likes
I have LightroomCC 2015.  It's the only one I've had and though I can see my pictures, which  are all on an external drive, I cannot export them or work with them. I did download a new Indesign, which allowed me to see the cards, etc. I had stored, but I cannot work with the photos because the masters are all unavailable on the external drive!

Pretty irresponsible of Apple to release Catalina knowing that it wouldn't work with Adobe specially as Apple has pretty much give up photography to Adobe.

Thanks for your note.

This conversation is no longer open for comments or replies.