LR5 Takes an age to process any rating filter that I apply to library module

  • 1
  • Problem
  • Updated 4 years ago
LR5 Takes an age to process any rating filter that I apply to library module
Photo of Inspire Photography Ltd

Inspire Photography Ltd

  • 5 Posts
  • 0 Reply Likes
  • frustrated

Posted 5 years ago

  • 1
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 3846 Posts
  • 1271 Reply Likes
Sorry to hear that... but we'll need more information before we can help.

For a start, which LR5 version are you running? 5.0? 5.2? 5.3RC?

And what operating system? On what spec machine?

How many photos in your catalog? Optimized it recently?

When you're filtering, do you have All Photographs selected, or a smaller folder/collection?
Photo of Inspire Photography Ltd

Inspire Photography Ltd

  • 5 Posts
  • 0 Reply Likes
I have LR 5.2 on mountain lion 10.8.5 on an iMac 21.5-inch, Mid 2010, 3.2 GHz Intel Core i3, 16 GB 1333 MHz DDR3,ATI Radeon HD 5670 512 MB.

I have just upgraded to 5.2 from LR4 so I would of thought that would of optimized the cataloge during the upgrade.

I do have 813,000 photos in my library, but only ever filter the smaller folder of say 500 images.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 3846 Posts
  • 1271 Reply Likes
One of the bugs fixed in 5.3RC was to do with optimize catalog, so updating to that from http://labs.adobe.com would be worth a shot.