LR5 seizes computer after Dock adjustment, or rearranging in dock. Force quit no help

  • 1
  • Problem
  • Updated 4 years ago
  • Solved
I have a MacBook Pro Retina. OXS 10.8.4 Just loaded LR5 from a disk. Version 5.0 Camera Raw 8.1 No updates avail for either.
First thing I wanted to do was "Keep in Dock" the icon/shortcut. The moment I tried to select it and move it across the bottom of the screen/reorganize it in the dock, it locked my whole computer up. A force quit on LR didn't help. Everything but cursor was frozen. I uninstalled LR5 and tried a fresh re-load. Same problem. Every time I opened LR5, and tried to move the icon in the dock, it froze. In the APP pages, I moved the icon from one page to another, and then went back to the dock. This was the ONLY time I was able to move it in the dock. every attempt after this, was a restart, to gain function to the computer again. I can video this and post it somewhere if it helps. Also, the double finger tap/"right click" feature didn't work on LR5 either, to try and add to dock or remove from dock.
When everything froze, with small windows (three finger swipe up), the cursor would actually be able to select things on the minimized windows, but never actually open them back up full size again.
Photo of Tony Reimer

Tony Reimer

  • 3 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of Benjamin Warde

Benjamin Warde, Employee

  • 483 Posts
  • 72 Reply Likes
Official Response
Hi Tony,

As it turns out, this is an Apple bug. We reported the bug to Apple and they've fixed it in 10.10. So if you wish, you can fix this by upgrading to 10.10 when it becomes available.

(To anyone on the team reading this: Watson bug 3633147, Radar bug 17328649, tested and found fixed in 10.10 build 14A298i.)

Thanks,
Ben