LR5 has become soooooo SLOW....... please bring back the LR4 performance!

  • 3
  • Problem
  • Updated 5 years ago
almost everything in LR5 is A LOT slower than it was in LR4... starting the program, starting a slideshow (if it ever gets started at all), and first of all editing the images.
when i change something, let's say play with the contrast slider, and i have turned on the display of lights and shadows that may get lost (in red and blue), the displayed result is almost too slow to work with. the red and blue marked areas first are not marked anymore while my hand is on that slider and i have to let go and wait for the result. even if its just 2 seconds, it was sooooo much better in LR4 because all the changes were displayed in the image instantly. thats not only for the over/underexposure markings, but for sharpness, noise, colors etc. as well. it looks like LR5 is running through every applied change that i made previously when i change something else, but that causes an annoying flickering in the image that makes it almost impossible to judge the image quality that i want to achieve. again, it worked well in LR4, so please please please bring back that LR4 perfomrmance!
Photo of geogre

geogre

  • 6 Posts
  • 0 Reply Likes
  • frustrated

Posted 5 years ago

  • 3
Photo of ERIC BURLET

ERIC BURLET

  • 69 Posts
  • 3 Reply Likes
In my case, starting the program is OK, it is the brush that is soooooooooo SLOW ! Even when lens corrections are off.

Come on Adobe, no new features but a really fast software ! Time is money...
Photo of Bill Young

Bill Young

  • 16 Posts
  • 0 Reply Likes
have you seen this post? do you have lens corrections applied?
LR5 on Win7: Spot Removal tool brush does not resize quickly or smoothly.
Photo of Greg Lundgren

Greg Lundgren

  • 12 Posts
  • 1 Reply Like
Lens corrections are a red herring in my opinion. I can't even cull photos in the library module without having to kill LR every few minutes. It completely takes down my system before I even attempt to develop anything. 4.4 had zero performance issues. LR5 is unusable.
Photo of Rob Cole

Rob Cole

  • 4831 Posts
  • 382 Reply Likes
Y'all got some strange problems - Lr5 is, in general, when things are working properly, a tad faster than Lr4. That said, it would help if you can trouble-shoot which elements of your system (or Lr-data..) are not playing nice with Lr5 (or vice versa) - I never said it would be quick or easy, or even doable - sorry: that's all I got.

Have you tried the usual stuff: delete prefs, retry with new catalog, ... , ... , ... (?)
Photo of Greg Lundgren

Greg Lundgren

  • 12 Posts
  • 1 Reply Like
Tried all the usual suspects. This is very weird -- and the fact it's happening on two different systems is very suspicious. It seems like it has to do with journaling the reject/select attribute changes -- but that makes no sense to me.