LR5.2 RC Spot removal feather bug

  • 1
  • Problem
  • Updated 5 years ago
LR5.2RC is breaking the Spot removal tool settings set in LR 4.x and earlier Specifically, the Feathering option is getting reset to 'zero' for all clone spots.
Here is a link to an image uploaded to Flicker in November 2012.http://farm9.staticflickr.com/8057/82...
here is that Same image on SmugMug uploaded in August 2013
http://cletus-lee.smugmug.com/HCC-Com...

I can open any such image In LR and when the preview gets rebuilt, the zero Feather gets applied because there may be any overlapping spots in the image is it impossible to re adjust each to some appropriate feather value The zero feather setting results in sharp edges seen on any export or any rebuilt preview.
Photo of Cletus Lee

Cletus Lee

  • 88 Posts
  • 20 Reply Likes

Posted 5 years ago

  • 1
Photo of Cletus Lee

Cletus Lee

  • 88 Posts
  • 20 Reply Likes
I've reverted back to LR 5.0 Apparently the 5.2RC introduced the Feathering adjustment and set feathering to zero. Prior to LR5.2RC cloned spots had a percentage of feathering built in and this was not an adjustable parameter. By adding the feathering adjustment AND setting the feather to a different value (0) than was present in prior releases, All clone operations prior to 5,2RC are now corrupted and unusable.
Photo of Cletus Lee

Cletus Lee

  • 88 Posts
  • 20 Reply Likes
With the final release of LR5.2 the problem has been corrected. Feather has been set to 90.

It would have put my mind at ease if this problem had been acknowledged here and Adobe had at least stated that this issue would be addressed in the final release.
Photo of Todd Shaner

Todd Shaner

  • 130 Posts
  • 10 Reply Likes
Please see my post here:

http://forums.adobe.com/message/56945...

In my Windows 7 LR5.2 Final install all images in my LR4.4.1 imported catalog with Spot Removal exhibit this issue! What OS are you running?
Photo of Cletus Lee

Cletus Lee

  • 88 Posts
  • 20 Reply Likes
I'm running OSX 10.8.4. In LR5.0 there was no feathering adjustment but there was feathering. In LR5.2RC a feathering adjustment was added, but it was set to zero for those spots that existed prior to LR5.2RC. In LR5.2 final the spot removal feathering was set to default to 90 (which may have been what it had been set to in prior versions of LR which had feathering but no feathering adjustment.
Photo of Todd Shaner

Todd Shaner

  • 130 Posts
  • 10 Reply Likes
So to be clear, all images that you edited in LR4 or earlier versions with the Spot Removal clone/heal tool now show in LR5.2 Final with Feathering set to 90?

I'm not talking about the the images you may have edited in LR5 or LR5.2 RC, just those edited in earlier versions (LR4, LR3, LR2, LR1 versions). On my Windows 7 system ALL of these prior version edited images with Spot Removal are set to zero '0' inside LR5.2 Final. I have never used LR5 or LR5,2 RC, because of all the issues. LR5.2 Final is the ONLY version of LR5 I've used.
Photo of Todd Shaner

Todd Shaner

  • 130 Posts
  • 10 Reply Likes
For anyone looking at this post there's an explanation as to what is happening in LR5.2 FINAL concerning Spot Removal clone spots during the LR4 (or earlier) catalog conversion:

http://forums.adobe.com/message/56994...

Adobe decided that it was best to default all prior image clone spots to '0' Feathering.

I ended up downloading and using AnyFilter to find images with Spot Removal applied and it works very well:

http://www.johnrellis.com/lightroom/a...