Lightroom: LR4 won't open - Unexpected error opening catalog

  • 4
  • Problem
  • Updated 5 years ago
  • (Edited)
I cannot open LR4. I get an, "Unexpected error opening catalog. The catalog could not be opened due to an unexpected error." What's up with this? So, what's the error, how do I fix it? This morning, after an auto update from Microsoft, I had problems booting up. Got back up, but had to revert to an earlier version, 23 June. I didn't think the revert would push LR4 to 23 June (that's what properties says). The catalog is for 24 June. Could this be the problem, and if so, how do I resync the catalog to the program? Otherwise, how do I recover without loosing all my book work?
Photo of Kevan Barton

Kevan Barton

  • 13 Posts
  • 8 Reply Likes
  • frustrated

Posted 6 years ago

  • 4
Photo of BethH


  • 3 Posts
  • 0 Reply Likes
error message when opening Lightroom that reads "this catalog cannot be opened due to an unexpected error"

This reply was created from a merged topic originally titled
Lightroom 4.2: catalog cannot open due to unexpected error.
Photo of Paul Kleczka

Paul Kleczka, Employee

  • 44 Posts
  • 5 Reply Likes
Hi Kevan-

I attempted to send you a private email with the hopes of debugging this issue and determining the root cause but unfortunately I received an email undeliverable notice using the email on your profile. If you are interested in helping us debug could you update your profile with a current email and post a note here when you have done so?

Photo of Gillian Guest

Gillian Guest

  • 2 Posts
  • 0 Reply Likes
Has anyone found the solution to this problem please.

I am running LR4 on my pc with Windows 7 service pack 1.
It just shows one of my catalogs the other 3 are missing from the opening screen. I have tried ALT when opening it and clicking on the restore option. It shows a restore point in June (coincidence or what Kevan) but doesn't actually restore the programme.

Any help would be appreciated, don't really want to have to uninstall and lose everything in it.

Photo of Gillian Guest

Gillian Guest

  • 2 Posts
  • 0 Reply Likes

Have just solved my own problem thankfully.

I went on to the adobe site and downloaded the LR4.1 upgrade - 15 mins later I was in my LR4.1 programme with all my photos available. Phew !!

Hope the rest of you have been successful in getting back into your LR4