Lightroom: Edit In External Editor does not work/function

  • 218
  • Problem
  • Updated 7 years ago
  • Solved
  • (Edited)
I can not send images from LR4 to any external editor via Photo>Edit In. My system is Mac OS 10.7.3. Using the Edit In command fails to open the external editor and no error message results. This occurs whether the images have the 2012 Process Version applied or not. My external editors are primarily PSE10 and Nik Silver Efex Pro 2.0. This is an important part of my workflow.

I have reinstalled PSE10 and updated to the newest version of Silver Efex Pro.
Photo of JullieM

JullieM

  • 35 Posts
  • 2 Reply Likes

Posted 8 years ago

  • 218
Photo of Peter Broadbent

Peter Broadbent

  • 3 Posts
  • 6 Reply Likes
I'd be happy if the bug fix was to give all LR users a free copy of CS5 :D
Photo of Peter Corradetti

Peter Corradetti

  • 7 Posts
  • 8 Reply Likes
If Adobe is aware of thousands of users with problems with Lightroom 4, why don't they just pull it from the download site so that others don't get frustrated with the buggy program? Adobe, be honest and admit there is a major issue with the final release of LR 4 and hold off any more downloads and purchases. By not admitting the problem and allowing buyers to purchase a defective product is not an honest thing to do.
Photo of JustMe06

JustMe06

  • 6 Posts
  • 5 Reply Likes
Greetings

On the Lightroom Forums I posted a temporary patch I was able to base off a Adobe Kb article that Nik Support pointed another user too. It should provide a sufficient work around until the patch is released. It does not use the install of Photoshop or Elements.

I only run windows machines and all seems good for them now. I dont have a mac so could only guess for that OS. It starts on page 4

http://forums.adobe.com/message/42579...

I included a farily long detailed post that I tried to explain the what and why, but the post after I think might be a bit more helpful for people just wanting Lr4 to work.

Hope it helps
Photo of Robert Scontrino

Robert Scontrino

  • 2 Posts
  • 0 Reply Likes
Works like a charm. Thanks!!!
Photo of Ivan Sinigaglia

Ivan Sinigaglia

  • 2 Posts
  • 3 Reply Likes
Now everything is working fine - Nik and CS5.1 (Win7) - after applying this adobe correction: http://kb2.adobe.com/cps/401/kb401629...
Thanks a lot.
Photo of james thomson

james thomson

  • 5 Posts
  • 1 Reply Like
That's really disappointing. The same bug in Lightroom 3 and they didn't make sure it wasn't present in Lightroom 4.
Even worse they know how to fix it, but haven't yet released a patch.