Lightroom: Edit In External Editor does not work/function

  • 218
  • Problem
  • Updated 6 years ago
  • Solved
  • (Edited)
I can not send images from LR4 to any external editor via Photo>Edit In. My system is Mac OS 10.7.3. Using the Edit In command fails to open the external editor and no error message results. This occurs whether the images have the 2012 Process Version applied or not. My external editors are primarily PSE10 and Nik Silver Efex Pro 2.0. This is an important part of my workflow.

I have reinstalled PSE10 and updated to the newest version of Silver Efex Pro.
Photo of JullieM

JullieM

  • 35 Posts
  • 2 Reply Likes

Posted 7 years ago

  • 218
Photo of Ralph Burkhart

Ralph Burkhart

  • 3 Posts
  • 0 Reply Likes
Where's the final release?
I don't want to install an English version of LR, I need LR in German.
And I need that problem fixed until end of next week.
Photo of Joe Santacroce

Joe Santacroce

  • 9 Posts
  • 1 Reply Like
I installed the LR4.1RC which fixed the editor problem but crashed multiple times and was so slow it was unusable. So unless this is ficed and a new release available, someone tell me how to get a refund please.

Thanks
Photo of John Zawacki

John Zawacki

  • 24 Posts
  • 0 Reply Likes
I must agree. I had to go back to using 3.4.
LR4.1 RC is slow and unstable. I tried it again yesterday and it locked up in develop mode when making adjustments to a very large file( 160 MB).
Photo of Andre Ferrer

Andre Ferrer

  • 20 Posts
  • 7 Reply Likes
Hello...Adobe...is anyone from your company paying attention to this thread? When will the actual 4.1 release be available in a version that both fixes this problem and is stable and snappy when doing so?
Photo of Andre Ferrer

Andre Ferrer

  • 20 Posts
  • 7 Reply Likes
Credit where credit is due, thanks Adobe! The 4.1 official release fixes this issue (for me without further complications) and appears to run much faster than 4.0 did.
Photo of Michael Greenley

Michael Greenley

  • 6 Posts
  • 0 Reply Likes
I found another small bug...in case Adobe is still listening to this thread!

When you apply "Remove Chromatic Aberration" and then export the file to PS CS6, the settings don't carry over. The aberrations reappear once imported into Photoshop.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4960 Posts
  • 1925 Reply Likes
It's difficult to find new replies when they're buried in 3 month old comments! Can you confirm LR version number and ACR version number please?
Photo of Daniel Arbeeny

Daniel Arbeeny

  • 46 Posts
  • 0 Reply Likes
I was told that LR will not work with Edit In with premiere elements 10. Can anyone verify this?
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4960 Posts
  • 1925 Reply Likes
That's correct Daniel, Lightroom doesn't have any direct ties with Premiere Elements for videos, unlike Photoshop Elements for photos. There are workarounds - what are you trying to accomplish?
Photo of Daniel Arbeeny

Daniel Arbeeny

  • 46 Posts
  • 0 Reply Likes
I now have a Sony NEx 7 and am taking photo's but also more video's. I have had enough times where i was required to edit the video's but without the linkage it makes life much harder (finding files which at times are in different folders, saving them back to a location and not knowing if they are int he catalog, etc). because everything is manual. Is this a feature request I can make or is it because it is elements version that they did not do it. The reason I moved away from PSE & PRE was that I now have a catalog of over 38k files which are realy unusable in PSE.
Photo of Daniel Arbeeny

Daniel Arbeeny

  • 46 Posts
  • 0 Reply Likes
I shoudl also say that I am new to LR and just startign to learn it. My primary use is for cataloging but I am also trying to learn how to use develop more. I use PSE10 for more complex editing (like moving heads from one image to another).
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4960 Posts
  • 1925 Reply Likes
I'm not that familiar with Premiere, but there's a plug-in called OpenDirectly which may be able to help you open the files. http://www.beardsworth.co.uk/lightroo... And yes, it's certainly worth a feature request. Vote on this one if you haven't already: http://feedback.photoshop.com/photosh...
Photo of Allen McAvoy

Allen McAvoy

  • 8 Posts
  • 2 Reply Likes
I echo that feeling. Adobe, could you please have someone acknowledge this thread. And can you let us know with a ballpark estimate when will a final 4.1 release be available.
Photo of William Martin

William Martin

  • 5 Posts
  • 0 Reply Likes
LR4 does not allow "Edit In" to Photoshop Windows CS5.1-64bit. Edit in photoshop is grayed out. External editing to CS5.1 or 3rd party gives "Unexpected error performing command, bad argument #1 to 'Lower' (string expected, got nil)"

This reply was created from a merged topic originally titled
LR4 does not "Edit In" to CS5.1.
Photo of William Martin

William Martin

  • 5 Posts
  • 0 Reply Likes
Downloaded and installed LR 4.1 RC2 / Camera Raw 7.1 from Adobe Labs. Problem with external editing to Photomatrix appears to work. However, editing in Photoshop CS5.1 still does not work. The link to "Edit in Photoshop" is grayed out as are links to open in Photoshop for Panorama, HDR, Smart Objects and Layers. Photoshop CS5.1 is uptodate with Camera Raw 6.7.
Photo of William Martin

William Martin

  • 5 Posts
  • 0 Reply Likes
Re-installed Photoshop CS5.1 and problem was resolved. All referenced Photoshop links in "Edit In" are present and working. Looks like an install issue.
Photo of Andreas Engelhardt

Andreas Engelhardt

  • 5 Posts
  • 0 Reply Likes
I cannot export a foto from Lightroom in Adobe Photoshop. I use Lightroom 4.1 and Photoshop Elements 10. In the menue-list the export is gray ("other editors" is black and the foto is not exported in PS.

This reply was created from a merged topic originally titled
Export from Lightroom 4 in Elements 10 not possible.
Photo of Andreas Engelhardt

Andreas Engelhardt

  • 5 Posts
  • 0 Reply Likes
A slected photo in LR4 can't be exportet for further development in Adobe PS10. I have posted this problem but no answer from Adobe until now!

This reply was created from a merged topic originally titled
I can't export a photo from LR to Elements 10!.
Photo of Dorin Nicolaescu-Musteață

Dorin Nicolaescu-Musteață, Champion

  • 703 Posts
  • 39 Reply Likes
Did you try the registry fix?
Photo of Richard Solly

Richard Solly

  • 2 Posts
  • 0 Reply Likes
I did download 4.1 LR. That fix most of the problem. However on some photos, even recent ones, I can not use my external editor in Photoshop Elements. How do I try "the registry fix?" Richard
Photo of Andreas Engelhardt

Andreas Engelhardt

  • 5 Posts
  • 0 Reply Likes
I can't understand why Adope is not able to fix that problem. Apparently, many users had that problem! Until now it is not completly solved...
Photo of Rudolf Schieben

Rudolf Schieben

  • 3 Posts
  • 0 Reply Likes
With Lightroom 4.1 Photoshop Elements 10 is now starting, but it didn't open the foto selected in Lightroom. System is Mac OS X 10.7.4

This reply was created from a merged topic originally titled
PSE 10 as external editor.
Photo of Richard Barry

Richard Barry

  • 50 Posts
  • 0 Reply Likes
I'm really not sure if this is a LR 4.1 or a PS CS6 issue... I am trying to 'edit in Photoshop CS6' from LR4.1 but when I click the button, nothing happens.

Serious issue for me so hoping someone has a fix.

Cheers

This reply was created from a merged topic originally titled
Lightroom 4.1 Edit In - function doesn't respond.
Photo of Susan Barr

Susan Barr

  • 12 Posts
  • 0 Reply Likes
Mac OS X 10.7.4 or 10.8
Lightroom 4.1
Photoshop CS6 Extended

Selecting a RAW file in Lightroom and clicking on "Edit in Photoshop CS6" launches Photoshop but the image does not appear in Photoshop.

Selecting a JPG file in Lightroom, clicking on "Edit in Photoshop CS6" then selecting "Edit with Lightroom Adjustments" launches Photoshop but the image does not appear in Photoshop.

Selecting a JPG file in Lightroom, clicking on "Edit in Photoshop CS6" then selecting "Edit a copy" launches Photoshop with the image in Photoshop.

I have tried deleting the Photoshop plist file in the user library and relaunching Photoshop. This did not cure the issue.

On Windows 7 x64 I do not experience these issues.

This reply was created from a merged topic originally titled
Lightroom 4.1: Edit in Photoshop CS6 does not work for RAW files on OS X 10.7.4 or 10.8.
Photo of Susan Barr

Susan Barr

  • 12 Posts
  • 0 Reply Likes
All updates have been applied to Photoshop CS6 Extended, including ACR 7.1.

When I open CR2 (Canon 5D mk III RAW ) files in Photoshop it opens into the ACR dialog correctly. However, to accomplish this in the Mac version I have to either use File Open or DRAG the file from mini-Bridge. Double clicking mini-Bridge CR2, DNG and PSD files does not open the image in Photoshop Mac.

Double clicking CR2, DNG and PSD files in Bridge correctly opens the image in Photoshop.

All this works correctly from Lightroom and mini-Bridge on my Windows version.
Photo of Susan Barr

Susan Barr

  • 12 Posts
  • 0 Reply Likes
Further note:

Lightroom was purchased as a standalone product prior to the release of CS6.

Photoshop is a CreativeCloud product.

All Adobe products were a fresh install on a MacBook Pro Retna early in July. At that time the OS X version was 10.7.4. When Mountain Lion was released, I upgraded to the new version.
Photo of Rikk Flohr

Rikk Flohr, Champion

  • 1373 Posts
  • 341 Reply Likes
Off hand, I would try a repair install of CS6. That normally restores the link.
Photo of Susan Barr

Susan Barr

  • 12 Posts
  • 0 Reply Likes
@Rikk: I just used the Photoshop Uninstaller and reinstalled from CreativeCloud. Unfortunately, the behavior described above continues:

PSD, CR2 and DNG files do not open in Photoshop from mini-Bridge by double-clicking. You can open them by dragging the image.

Lightroom CR2, DNG, PSD files do not open in Photoshop using "Edit in Photoshop". Lightroom JPG files do not open in Photoshop using "Edit in Photoshop" with "Lightroom Adjustments". JPG do open if you select "Edit a Copy" or "Edit Original".
Photo of Susan Barr

Susan Barr

  • 12 Posts
  • 0 Reply Likes
Thanks to a suggestion on another forum, I have solved my problem by creating a new Lightroom Catalog and importing my photographs.
Photo of Russ Olney

Russ Olney

  • 1 Post
  • 0 Reply Likes
I have downloaded Lightroom 4.1 and reinstalled Photoshop Elements 10 which seemed to solve the problem for others but it has not worked for me. Any other suggestions?

This reply was created from a merged topic originally titled
Lightroom: Edit In External Editor does not work.
Photo of Peter Simons

Peter Simons

  • 4 Posts
  • 0 Reply Likes
I can not get Lightroom 4 to edit in an external editor. Running OS X 10.7.3 I have tried Photoshop elements 9 and Portrait professional without success. The beta version of Lightroom 4 worked fine.

This reply was created from a merged topic originally titled
Lightroom 4 and external editor(s).
Photo of Daniel Arbeeny

Daniel Arbeeny

  • 46 Posts
  • 0 Reply Likes
On Windows 7 & Windows 8 LR to PSE works but LR to PRE does not. I believe that Adobe has not implemented that feature.
Photo of sharon milligan

sharon milligan

  • 4 Posts
  • 0 Reply Likes
I have lightroom 4.1 and Premier Elements 9. They have been working together fine for as long as I have had them until a few days after installing Perfect Photo Suite 7. Now the only edit in features I have are the suite and elements is grayed out. If I try to add it back manually, I get an error. Tech support for LR told me to purchase elements 11 that they can't help me.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15462 Posts
  • 2290 Reply Likes
sharon, what's the specific error you're getting?

Did you try the solution found at the top of this page?
Photo of sharon milligan

sharon milligan

  • 4 Posts
  • 0 Reply Likes
I have not had a chance to spend any more time on it since I found this page. The error just says an error occured, nothing more specific. I did just notice that it does not mention the editor anywhere, just elements 9 and elements organizer. I could not find any place under programs in the hard drive that mentions the editor by name either.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15462 Posts
  • 2290 Reply Likes
Sounds like you have the alias selected and not the editor. See the Official Response at the top of this page. It should help.
Photo of sharon milligan

sharon milligan

  • 4 Posts
  • 0 Reply Likes
Thank you Jeffrey. I finally had time to try your suggestion. It took a bit of looking to find just where the editor was located, but I did find it and it worked beautifully. Now my LR talks to my Elements again. Don't know how it was ever disconnected to begin with, but I am happy now.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15462 Posts
  • 2290 Reply Likes
Excellent. Thanks!
Photo of Daniel Arbeeny

Daniel Arbeeny

  • 46 Posts
  • 0 Reply Likes
Sharon: I just want to make sure I understand, by Premier Elements 9 do you mean PSE or PRE?
Photo of sharon milligan

sharon milligan

  • 4 Posts
  • 0 Reply Likes
Sorry, I have the combo version, but it was the PSE I was actually referring to. I have not been using the premiere part of the software.