LR4 crashs with "LoadLibrary failed with error 126" on video playback

  • 2
  • Problem
  • Updated 6 years ago

I downloaded/installed the LR4 trial version and upgraded my existing LR 3.6 catalog.

LR 4 crashes with:

LoadLibrary failed with error 126: Das angegebene Modul wurde nicht gefunden.

when I try to play (double click or E Loupe view) my Fuji F30 AVI or NEX-5N MTS AVCHD videos.

Just moving the mouse horizontally over the video preview icon works and shows the video as single frames.

Some Hardware/Software data:

Notebook Acer Aspire 7750G, i5-2450M, 8 GB RAM
ATI/AMD Radeon HD 7670M 2048 MB SDRAM (with latest driver version 8.901.4.0)
Windows 7 Home Premium (x64) Build 7601 Service Pack 1

LR4 reports with Menu Help / System Info...

Lightroom version: 4.0 [814577]
Operating system: Windows 7 Home Premium Edition
Version: 6.1 [7601]
Application architecture: x64
System architecture: x64
Physical processor count: 4
Processor speed: 2,4 GHz
Built-in memory: 8043,8 MB
Real memory available to Lightroom: 8043,8 MB
Real memory used by Lightroom: 197,9 MB (2,4%)
Virtual memory used by Lightroom: 185,5 MB
Memory cache size: 131,1 MB
System DPI setting: 96 DPI
Desktop composition enabled: Yes
Displays: 1) 1600x900
Application folder: C:\Program Files\Adobe\Adobe Photoshop Lightroom 4
Library Path: C:\Users\jp\Pictures\Lightroom\Lightroom 4 Catalog.lrcat
Settings Folder: C:\Users\jp\AppData\Roaming\Adobe\Lightroom
Audio and Video info: Loading

...and then it also dies with a
LoadLibrary failed with error 126: Das angegebene Modul wurde nicht gefunden.

My computer is only three month old and I would say it is relatively clean. No fancy hacks,
cracks, patches installed or otherwise tricky programs running in the background.

I have saved the following crash dump files:
If somebody from Adobe would be interested...

There are other threads about video problems with LR4, but I wonder that nobody mentions
the LoadLibrary failed error. Another thread and the release notes mention that Norton may
remove mc_enc_dv.dll resulting in video problems. I don't have Norton running and also have
checked for mc_enc_dv.dll - it's there in my install.
Photo of Justin Pletzfeld

Justin Pletzfeld

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 6 years ago

  • 2
Photo of Holger Dresel

Holger Dresel

  • 2 Posts
  • 0 Reply Likes
I have a similar problem. No crash but the avis don't play either.

My configuration is:

- Win 7 64bit
- AMD 6core processor
- 8GB Ram
- ATI Radeon HD 5770 graphics card (newest driver).

AVIs are from a Canon Ixus 95 IS.
When playing avis with the Windows media player everything works well. In Lightroom the video play bar is visible but not usable.
Photo of Becky Sowada

Becky Sowada, Adobe Employee

  • 506 Posts
  • 102 Reply Likes
Justin, I'd like you to try something, just to eliminate some variables. If you remove one of the videos that exhibits the problem from the catalog, then import it again, does it play?

Photo of brian brains

brian brains

  • 69 Posts
  • 5 Reply Likes
LoadLibrary 126 Error:

This is a bug in the OpenGL software and can't be fixed by reverting to an earlier version.

There are two solutions. The first involves using a command window and in windows\system32 enter this command

copy atioglxx.dll .dll

In some instances this works as a bug in ATI/AMD's software is looking for the file .dll instead of atioglxx.dll This didn't work for me but did for others.

The other solution is to updrade to the Catalyst 4.2 OGL Preview software from the AMD site. This sorted all OpenGL errors for me incl LR4 CS5 and plugins that use OpenGL incl stitch panorama in Photoshop etc.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13635 Posts
  • 1546 Reply Likes

Determine what video card you have and go directly to the manufacturers website (nVidia or ATI/AMD) and download the latest driver. Let us know if that corrects the problem.
Photo of brian brains

brian brains

  • 69 Posts
  • 5 Reply Likes
If its AMD then the latest retail release won't fix it, it needs to be the beta.
Photo of Justin Pletzfeld

Justin Pletzfeld

  • 2 Posts
  • 0 Reply Likes
Removing and importing the videos didn't help and as I already said, I have a new notebook with the latest manufacturers drivers installed.

After more research I think the problem is really due to some AMD OpenGL installation bug. Thanks to brian brains for this hint.

It seems the LoadLibrary 126 error is a well known problem with AMD OpenGL software as there are many discussions and possible solutions around (mostly gamer boards). Unfortunately none of the given solutions worked for me. In the end I took all the input and came up with my own solution.

One hint was towards the registry entry HKLM\SYSTEM\CurrentControlSet\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0000 with OpenGLVendorNameWow set but OpenGLVendorName missing.

My registry had both entries set as:
OpenGLVendorName atiogl64.dll ig4icd64.dll
OpenGLVendorNameWoW atioglxx.dll ig4icd32.dll

BUT there was no atiogl64.dll in my Windows\System32 directory! Copying a atioglxx.dll from the depths of Windows\System32\DriverStore\FileRepository\... to Windows\System32 at least silenced the LoadLibrary 126 error but reported LoadLibrary 193 "not a valid Win32 application". Where to get atiogl64.dll?

In another gamer board thread it was stated that atio6axx.dll is the 64-bit version of atioglxx.dll. I copied Windows\System32\atio6axx.dll to Windows\System32\atiogl64.dll and video playback in LR4 worked!!!

Don't ask me if my solution is correct - at least ist seems to work (for me).

The suggestion to install the AMD OpenGL 4.2 Beta software may have also worked as this could fix the installation in some way but I didn't want to change this much in my system. Copying one dll as a fix is ok with me until I find new problems due to this...