Lightroom: LR4: Coloured 'sort by' now not stacking

  • 1
  • Problem
  • Updated 6 years ago
  • (Edited)
As well as my previous post on how the coloured 'sort by' system doesn't stack the selected images as it used to in all previous versions but now I have found yet another time-wasting bug. Some of my images have 3 or 4 versions - if an image has more than 4, LR only stacks the first 4 versions. The other ones are left un-stacked - just floating around really.

Which isn't helpful.
Photo of Richard Barry

Richard Barry

  • 50 Posts
  • 0 Reply Likes
  • frustrated

Posted 6 years ago

  • 1
Photo of Becky Sowada

Becky Sowada, Adobe Employee

  • 508 Posts
  • 105 Reply Likes
I need some more information to investigate. What OS version are you using? How are the versions created? Are they virtual copies?
Photo of Richard Barry

Richard Barry

  • 50 Posts
  • 0 Reply Likes
Win 7 64-bit

The versions are created by using external editors - such as Photoshop - usually saved as TIFFs.

What you get is the initial stack of say 3 images, then if there are any other versions of the same image, they are not stacked at all, even if they're the same colour or rating.

It's truly bizarre.

Let me know if you need any more information.
Photo of Richard Barry

Richard Barry

  • 50 Posts
  • 0 Reply Likes
And I'm still waiting Becky.

The stacking issue on LR4 is completely odd-box. Can you guys do a video on how to use this new 'feature' which seems so much like a bug.
Photo of Becky Sowada

Becky Sowada, Adobe Employee

  • 508 Posts
  • 105 Reply Likes
Richard, we've been looking at this but have not once been able to see the bug happen. Is there any other information you can offer to clarify? Maybe if you did a video capture that walks through the steps you take to see the bug, that might help. (if you don't have a video capture utility, there are several available for free. I use Jing, which seems to work well on both Win and Mac systems.)
Photo of LRuserXY

LRuserXY

  • 426 Posts
  • 41 Reply Likes
Are the images stacked correcly when sorted e.g. by file name? In other words: Is the problem only visible when sorting by color label, or is it a general problem?

If it is a general problem: In preferences, external editing, there is a new option "stack with original". Edited TIFFs are only stacked if this option is activated. A similar option is available in the export dialog if the file is exported to the same folder as original and "add to catalog" is activated.

P.S. Already stacked images (7 images in stack) behave as expected on my system (4.1 RC, 64Bit, Win7), i.e. the stack stays together when sorting by color, no matter what their actual colors are.