LR4 assigning keywords to multiple photos is buggy

  • 1
  • Problem
  • Updated 7 years ago
Assigning keywords for multiple selected photos in library module:
When view is in Grid View mode -> keywords are assigned to all selected photos.
When in Loupe View mode -> keywords are only assigned to the visible photo, altough multiple photos are selected in filmstrip on bottom.

Unfortuantely I have already uninstalled LR3, but I bet this was working there...
Photo of Sandra Seilmann

Sandra Seilmann

  • 5 Posts
  • 0 Reply Likes

Posted 7 years ago

  • 1
Photo of jdv

jdv, Champion

  • 728 Posts
  • 56 Reply Likes
I'm pretty sure this how it worked for Lr3, as well. The filmstrip is not a selection in the typical sense.
Photo of Beat Gossweiler

Beat Gossweiler

  • 238 Posts
  • 38 Reply Likes
Works the same in LR3, unless you have AutoSync enabled in Library.

Beat
Photo of Sandra Seilmann

Sandra Seilmann

  • 5 Posts
  • 0 Reply Likes
I still think this is not a consistent behaviour. While in loupe view I can select multiple photos from the filmstrip an can delte all of them. Why should one not be able to apply keywords to the selected ones?
Photo of Becky Sowada

Becky Sowada, Adobe Employee

  • 508 Posts
  • 105 Reply Likes
In Library Loupe view, you can apply changes to multiple photos in the filmstrip, but only by right-clicking on the filmstrip and using the resulting context menu. When you do this, Lightroom knows that you are clicking on the filmstrip, and can correctly interpret your intent to apply the change to all photos selected in the filmstrip.

When you are trying to apply a change using another method that doesn't involve directly clicking on the filmstrip, Lightroom doesn't know for certain whether you want to apply it to just the currently photo in Loupe, or to a wider selection. As a result, it only applies the change to the photo in Loupe. Thus, if you delete photos using the Delete key on the keyboard, only the photo currently being viewed in Loupe will be deleted, regardless of what you have selected in the filmstrip.

This is how Lightroom has worked from the start; it is not new to Lightroom 4.