Lightroom: LR4.1RC Video Functionality Intermittent.

  • 1
  • Problem
  • Updated 7 years ago
  • (Edited)
Also: Possible problems if 3.6 is uninstalled after 4.1 installed.

Video functionality in LR4.1C is intermittent. It worked fine in 4.0 but not after an install of 4.1RC. After a week of testing and a 4.1RC crash, it started working again.

1. Started with LR 3.6 with 30,000 images.

2. Installed 4.0 and converted catalog to 4.0.

4. All video types showed thumbnail, shuttle and player functions.

5. Loaded 4.1RC. All video functionality was broken.
video thumbs showed "Render error" and a strange "photo has error" alert.

7. Deleted entire preview cache. Re-rendered all 30,000 overnight.

8. Video thumbs then showed "Render Error" and a "video has error" alert.
Same loss of video function but at least error said "video" this time.

This problem was very consistent and remained for over a week of heavy usage and testing of 3.6 and 4.1RC (not at the same time).

Then, as I was researching this major problem in more detail to report it here, I happened to invoke LR4.1RC while LR3.6 was still running. Although there were no errors, LR4.1RC did not present itself on the screens. When I selected the active LR4.1RC task, nothing happened except the current image of LR3.6 appeared on my 2nd display even though LR4.1RC was the currently selected active task. After a few switches back and forth between 3,6 and 4.1RC, 4.1RC eventually crashed out with an "Lightroom 64 bit error". I then closed LR3,6 so there were no LR's were running.

I then restarted LR4.1RC and was about to capture the screen of the video thumbnail problem and errors to report the problem here. But then ALL VIDEO FUNCTIONALITY was magically active and runjning wothout erros. All video thumbs rendered without error, the cool thumbnail shuttle worked, and the full video play also worked ... On all video formats.

So, there's something funky in LR4.1RC that initially caused it have video thumbnail render errors and no video functionality. It seems it was only by running 3.6 and 4.1RC together and the subsequent crash out of 4.1RC that caused it to start handling videos again.

Based on 4.1RC not displayhing anything when 4.6 was running seems to such there are commin binaries being used by both versions. That is very worrisome since we will want to uninstall 3.6 when 4.x is eventually fixed and acts like a Gold release rather than an unstable and slow alpha.

Captures of when 4.1RC video functions did not initially work.

Video thumbnail with render error alert flag:



Video thumbnail with render error message displayed:



As noted earlier, this video thumbnail render and functionality returned to normal after a 4.1RC crash when attempting to run 3.6 and 4.1RC at the same time. Since 3.6 and 4.1RC have different catalogs in different folders, the programs are separate binaries in separate folders, and installing the latter does nothing to the former, one might assume concurrency was possible. I think a code review is in order.
Photo of TK Anthony

TK Anthony

  • 13 Posts
  • 0 Reply Likes
  • frustrated

Posted 7 years ago

  • 1
Photo of jdv

jdv, Champion

  • 728 Posts
  • 56 Reply Likes
I suspect you are using Windows, and have real-time anti-virus protection enabled. Try disabling that, or excusing Lr from it.